Results 1 to 9 of 9
  1. #1
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1

    02 virage i starting problems

    ok so I have good spark, took injectors off and swaped them with my 04 and the 04 still started so I ruled out the injectors, I checked injector paulsh (sp.) with a diode kit and have power going to both of them have about 20lbs of fuel pressure when cranking it over and then it seams like it loading up then will fire and want to sorta run or backfire. and that's all I can get out of it. I baught it not running and knew it needed some work so that intailed putting a starter, bendix, and stater in it which I did today and now the problem of which I stated above. any help would be grately welcome thanks ben


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Quote Originally Posted by ben01251979 View Post
    ok so I have good spark, took injectors off and swaped them with my 04 and the 04 still started so I ruled out the injectors, I checked injector paulsh (sp.) with a diode kit and have power going to both of them have about 20lbs of fuel pressure when cranking it over and then it seams like it loading up then will fire and want to sorta run or backfire. and that's all I can get out of it. I baught it not running and knew it needed some work so that intailed putting a starter, bendix, and stater in it which I did today and now the problem of which I stated above. any help would be grately welcome thanks ben
    You checked what with a diode kit? What is a diode kit?

  3. #3
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    its a kit that has diods that light up when u put power to them. u use them on cars and trucks to check for paulh in the plug that plugs in to the injector that's what I used to make sure I hade power going to the injectors on my pwc

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Quote Originally Posted by ben01251979 View Post
    its a kit that has diods that light up when u put power to them. u use them on cars and trucks to check for paulh in the plug that plugs in to the injector that's what I used to make sure I hade power going to the injectors on my pwc
    The Ficht fuel injectors are NOT like automotive fuel injectors. Entirely different.

    You must use a proper multi-meter to measure the actual voltage. The voltmeter measurement is between engine ground and the White/Red wires, NOT between the two pins on the injector connector.

    I still have no idea what paulh might be

  5. #5
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    pulse is what I was tring to say sorry have trouble spelling some times and all the diods are telling me is that there is currant going through the injector plug and there was. But if there is not enuf volts going to the injector it will cause it want to try and run but not? I went out and tried to start it again and it started but spit and spuddered a few seconds and that was it and if u keep trying to start it some times it acts like it is out of time and back fires and stops turning over like it is hydro locked, but set off the starter button and hit it again and it will crank right over for u

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Quote Originally Posted by ben01251979 View Post
    pulse is what I was tring to say sorry have trouble spelling some times and all the diods are telling me is that there is currant going through the injector plug and there was. But if there is not enuf volts going to the injector it will cause it want to try and run but not? I went out and tried to start it again and it started but spit and spuddered a few seconds and that was it and if u keep trying to start it some times it acts like it is out of time and back fires and stops turning over like it is hydro locked, but set off the starter button and hit it again and it will crank right over for u
    Backfiring is a classic symptom of a bad EMM engine computer module.

    If the EMM needs repair, then it needs repair. DFI Technologies is the primary repair service.

  7. #7
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    would u happen to have a website or telephone number for DFI Technologies by chance

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Quote Originally Posted by ben01251979 View Post
    would u happen to have a website or telephone number for DFI Technologies by chance
    Yep. See the Parts Sources section of my signature links.

    More DFI Technologies info on the Ficht section of those links.

  9. #9
    ben01251979's Avatar
    Join Date
    Jun 2013
    Location
    Portage, WI
    Posts
    143
    +1
    1
    thank u for all ur help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 01 Virage no start problem
    By A10ECGent in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 06-28-2010, 10:52 PM
  2. Newbie with an 02 virage 1200 txi problem
    By SS Bulldog in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-21-2010, 06:51 AM
  3. Need Help on '02 Virage TXi Starting Problem
    By bluedevil60 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-26-2009, 12:06 PM
  4. 2000 Virage strange starting problem
    By bclake in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 09-08-2007, 04:13 PM
  5. 02' Virage I Fuel Problem?
    By Ralph in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-15-2007, 12:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •