Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Firewalker918's Avatar
    Join Date
    Jun 2012
    Location
    Georgia
    Posts
    15

    Need more power to pull Tube on 02 4tec

    My 02 4tec struggles on start off when pulling someone on tube.

    Any advice for better "out of hole" power?
    Not wanting to spend lots of money but thought might be a few hundred dollar (or less) fix.

    thanks!!
    Fire


  2. #2
    04gtxsc's Avatar
    Join Date
    Mar 2006
    Location
    Kansas
    Posts
    3,090
    +1
    197
    It should pull the tube just fine normally. How big a tube and how many people are you trying to pull? Has it always been this way or did it just start to lose power?

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Something is up with the ski. I used to pull 2 tubes with a 1996 85hp GTI.

  4. #4
    04gtxsc's Avatar
    Join Date
    Mar 2006
    Location
    Kansas
    Posts
    3,090
    +1
    197
    On anther thread you have going you talk about an 03. Is it the supercharged one?

  5. #5
    Firewalker918's Avatar
    Join Date
    Jun 2012
    Location
    Georgia
    Posts
    15
    The date on engine is 06/2002 GTX 4tec , so maybe it is a 03?
    i bought used and it has been like this since I first put in water. Without a load it comes up and planes fine, even adding a passenger on back makes it Rear Heavy and seems sluggish.

    Someone suggested a Skat Track impeller but I am wonder if something is not right just because it wants to not plane out good when a passenger is on back.

    thanks for any and all advice.
    Last edited by Firewalker918; 06-27-2013 at 05:12 PM.

  6. #6
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    I would Change the Wear ring and upgrade the Impeller to a polished stainless one like Solas/Skat-Trac model But stay with the factory recommended blade pitch and you'll be happy

  7. #7
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Did those have the plastic pump in them?

  8. #8
    Does it feel like an old truck that has a slipping clutch?

  9. #9

    Join Date
    Jan 2009
    Location
    Scotland, UK
    Posts
    290
    +1
    9
    Quote Originally Posted by jp1300r View Post
    Did those have the plastic pump in them?
    Yes....the one in ours is plastic.

  10. #10
    Firewalker918's Avatar
    Join Date
    Jun 2012
    Location
    Georgia
    Posts
    15
    Quote Originally Posted by CanDooPro - Dennis View Post
    Does it feel like an old truck that has a slipping clutch?

    No it feels more like just struggling to pull. The tail goes what seems like to deep and the nose goes high, Its like if it had a trim you could trim engine down and it would plane out to pull.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. thoughts on good ride to pull tubes with
    By kentrx1 in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 01-20-2009, 12:25 PM
  2. 08 GPR needs more power! with warranty
    By syclonedriver in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 09-04-2008, 09:21 PM
  3. Need More Power
    By silvia13 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 03-24-2008, 12:08 PM
  4. Need more power
    By FreakRXP1200 in forum 4-Tec Performance
    Replies: 20
    Last Post: 03-12-2008, 07:04 AM
  5. Need More Power!
    By firechief in forum 2-Stroke Performance
    Replies: 0
    Last Post: 06-26-2007, 08:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •