Results 1 to 4 of 4
  1. #1

    No fuel flow - Polaris Genesis 1200

    Good day everybody,

    I bought a 2001 Genesis which had a wrecked engine. I completely replaced and rebuild the whole engine with new rings, gaskets etc. Its like new and when I wanted to start it nothing.....!

    I replaced the fuel pump in the fuel tank as I figured out there was now fuel flow. After replacing the pump still nothing...... I took out the intake hose to the injectors, turned the engine over and no fuel came out of the hose. Are you able to hear the fuel pump when the ignition is switched on? Because nothing happens when the ignition is switched on.

    I hope you guys can help me out so I can get the ski up and running soon.

    Thank you in advance!

    Best regards,

    Jacques


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Welcome

    Check the fuel pump fuse or Reset Button (circuit breaker).

    If fuse is good then use a thin pin or needle to ground the Brown wire at the fuel pump, with fuel pump plugged in. Fuel pump should run.

  3. #3
    Quote Originally Posted by K447 View Post
    Welcome

    Check the fuel pump fuse or Reset Button (circuit breaker).

    If fuse is good then use a thin pin or needle to ground the Brown wire at the fuel pump, with fuel pump plugged in. Fuel pump should run.
    Thank you very much I will check the fuse and let you guys know!

    Appreciate the quick reply!

    Best regards,

    Jacques

  4. #4
    Got it up and running guys thanks a lot! The guy who "fixed" it had the wires connected wrong way around. Now I just need to take it to the lake and test the ski!

    Jacques

    Quote Originally Posted by HHS View Post
    Quote Originally Posted by K447 View Post
    Welcome

    Check the fuel pump fuse or Reset Button (circuit breaker).

    If fuse is good then use a thin pin or needle to ground the Brown wire at the fuel pump, with fuel pump plugged in. Fuel pump should run.
    Thank you very much I will check the fuse and let you guys know!

    Appreciate the quick reply!

    Best regards,

    Jacques

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 polaris genesis 1200 carb no spark
    By bam7786 in forum Polaris Tech Tips and Info
    Replies: 3
    Last Post: 09-10-2016, 02:33 PM
  2. Needs help with my 2000 Polaris Genesis 1200 fuel injected
    By mchubbs in forum Polaris Open Discussion
    Replies: 16
    Last Post: 08-12-2014, 08:42 AM
  3. 2001 polaris genesis 1200 fuel injected
    By J4ke1990 in forum Polaris PWC Performance
    Replies: 24
    Last Post: 05-27-2014, 08:26 AM
  4. 1999 Polaris genesis 1200 carb NO SPARK
    By rjaro7 in forum Polaris Tech Tips and Info
    Replies: 10
    Last Post: 07-20-2013, 05:07 PM
  5. 1999 Polaris Genesis 1200 "Sleeper" project
    By SCXtrmSnwNWtr in forum Polaris Projects
    Replies: 23
    Last Post: 05-12-2007, 06:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •