Results 1 to 7 of 7
  1. #1

    Join Date
    Jul 2012
    Location
    fairhope alabama
    Posts
    149
    +1
    1

    Starter won't engage

    I got my 97 SLT 780 all back together today, hooked up the battery i had last year and all i herd when i pushed the starter was a click. So i went to get my battery charger, i put it on the start setting and the starter does turn but it won't engage the fly wheel, almost like there was no starter gear on it. I've tried tapping the starter with something but it does no good. Do i have to pull the motor back out to see about the starter?


  2. #2
    polarisjunky's Avatar
    Join Date
    Jun 2011
    Location
    kalamazoo,mi
    Posts
    149
    prolly have a bad bendix.. will have to pull flywheel to get to..

  3. #3
    Polarisitis loonatik's Avatar
    Join Date
    May 2010
    Location
    Tampa, FL
    Posts
    812
    +1
    10
    Starter --> Starter bendix --> Flywheel
    Sounds like starter bendix is stuck and not sprung forward when spins. Unfortunately you'll need to remove front cover and flywheel to get to it.

    Edit: Oh wait! The motor just got put in? Probably someone forgot to put it in

  4. #4

    Join Date
    Jul 2012
    Location
    fairhope alabama
    Posts
    149
    +1
    1
    Quote Originally Posted by loonatik View Post
    Starter --> Starter bendix --> Flywheel
    Sounds like starter bendix is stuck and not sprung forward when spins. Unfortunately you'll need to remove front cover and flywheel to get to it.

    Edit: Oh wait! The motor just got put in? Probably someone forgot to put it in
    what does one look like? i put ever thing back together on it

  5. #5

    Join Date
    Jul 2012
    Location
    fairhope alabama
    Posts
    149
    +1
    1
    Quote Originally Posted by polarisjunky View Post
    prolly have a bad bendix.. will have to pull flywheel to get to..
    where can i get one at?

  6. #6
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by cumminsbayou View Post
    Quote Originally Posted by polarisjunky View Post
    prolly have a bad bendix.. will have to pull flywheel to get to..
    where can i get one at?
    I've got one for you. But open up the flywheel cover and see if it is there.....? http://www.ebay.com/itm/1996-96-Pola...6195d2&vxp=mtr

  7. #7

    Join Date
    Jul 2012
    Location
    fairhope alabama
    Posts
    149
    +1
    1
    i fixed it guys all i had to do was buy a new battery my old one was from last year

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Starter won't engage
    By Just4fun in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-23-2013, 03:09 PM
  2. 98 zxi 1100 start button won't engage solenoid. HELP
    By Paulgibsonlgc in forum Kawasaki How To & FAQs
    Replies: 5
    Last Post: 08-22-2012, 04:04 PM
  3. 01 virage starter won't stop once button is pressed
    By mike2 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-23-2011, 03:02 PM
  4. Starter spins but won't engage
    By Squirtcha? in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-31-2009, 06:34 PM
  5. Ski quit running and starter will not engage??
    By Bryan K in forum Yamaha PWC Performance (2-stroke)
    Replies: 23
    Last Post: 07-15-2008, 10:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •