Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    1999 Polaris Genesis does not run above 6500 RPM

    My 99 polaris 1200 gensis fi jet ski cuts off at 6500 rpm what would cause it


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    What do you mean by 'cuts off'?

    Does the engine actually stop, or just not rev above 6500RPM on the water, at speed?

  3. #3
    It dies and you have to restart it.

  4. #4
    DFI rebuild the computer on it.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by alan83 View Post
    It dies and you have to restart it.
    Does it only die if you you run it at wide open throttle?

    6500 RPM is about where that engine should run at full throttle, maybe 200 RPM higher.

    How long does it run at full throttle before it quits?

    Does it restart immediately, or do you have to wait a minute?

    What other service work has been done on his machine?

  6. #6
    Yes if you open it all the way it dies it will run at 6400 as long as you hold it . I have put a coil on it and reglued the magnet in fly wheel when I got the computer back from DFI. I put a timing light on the plug wire rode it and watched the light and when it hit 6500 it loses fire .

  7. #7
    Yes it will start right back up when you hit the start button.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by alan83 View Post
    Yes if you open it all the way it dies. it will run at 6400 as long as you hold it.

    I have put a coil on it and reglued the magnet in fly wheel when I got the computer back from DFI.

    I put a timing light on the plug wire rode it and watched the light and when it hit 6500 it loses fire .
    Has the TPS ever been changed?

    My suspicion is that the TPS has a bad spot in the throttle position that just happens to correspond to 6500RPM on the water.

    If the TPS signal suddenly goes wildly out of whack while running the EMM doesn't know what to do, so I suppose it might decide to just kill the engine.

    On the trailer I expect it will rev just fine beyond 6500RPM, correct?

  9. #9
    Yes out of water it will turn max. Where can I get one from?

  10. #10
    I have never changed the tps

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 06-24-2015, 10:58 PM
  2. 2002 Genesis carburetor engine, does not run properly
    By Rob Robinson in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-17-2014, 10:51 PM
  3. 1999 Genesis, no start, fuel pump does not run when cranking
    By RIDEH2O in forum Polaris Open Discussion
    Replies: 22
    Last Post: 08-20-2013, 05:10 PM
  4. 1999 polaris genesis will idle but not rev up.
    By buzzard one in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-19-2011, 05:04 PM
  5. 1999 Polaris Genesis 1200 "Sleeper" project
    By SCXtrmSnwNWtr in forum Polaris Projects
    Replies: 23
    Last Post: 05-12-2007, 06:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •