Results 1 to 10 of 10

Thread: Oh dear !

  1. #1
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1

    Thumbs down Oh dear !

    Al
    Not a good day today .235 hrs Yamaha VX110 has crapped itself in a big heap of smoke and noise .Within 10 mins my brand new stx12f Kawasaki with 28 hrs gave a wimper and lots of smoke with a big miss .
    Mind you the old Xl 700's still going round and round .Will keep you posted

    Cheers

    Bernie


  2. #2

    Join Date
    Sep 2006
    Location
    topeka,ks
    Posts
    3,332
    maybe you should post is in the yami and kawi so we can hear those boys wimper

  3. #3
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    Shall do that when I find out exactly what went wrong ,I did say to Al that I would keep him posted on the ski's because they replaced Poolaris and I gave them a right ful bagging .

    Cheers

    Bernie

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Thanks Bernie,

    Love to hear how the Yami's are doing. I'm quite suprised you had an issue with the Kawi straight away I've been having second thoughts about my Ultra 250 due to paint issues. I can take care of anything else, but paint and body and I'm a gonner...........
    I guess we know why Yami has done so well in the rental fleets!!
    I do wish you would have been able to get the SLT780's, you would have had extremely AWESOME luck with those as well.

  5. #5
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu. Live In Los Angeles.
    Posts
    841
    Any electrical problems on the VX110s? A local rental co here didn't like the VX110s. They had lots of problems with them and went back to Kawi 12Fs. Then again, I remember a rental place in Havasu posting on pwct that he had lots of problems with their 12F fleet. I guess they all suck, or the renters/newbies do? I personally think the 2 stroke Yami 700s and the Polaris carbed 700s were the best rental type machines made.

  6. #6
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I've always had good luck with the 700 BUT a huge rental company went from the 780 to the 700 and wound up with a huge expense everytime the 700 lost the engine seal.
    I think the renter, severly shortens the life of the 700. The constant towing, WOT etc just wore that thing out in the large 3 seater platform.
    When we sold 25 units (780's) to a marina at Lake Don Pedro, we were only there once a month and that was usually just maintenace.
    I guess for that time I was just a Fuji fan.

  7. #7
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu. Live In Los Angeles.
    Posts
    841
    Bernie, Looks like the thread I was talking about in reference to the 12F is resurrected. Check it out here http://www.pwctoday.com/showthread.php?t=80689

  8. #8
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    Here I go Again.At least this time there is the internet to back me up .So when they say it hasn't happened to any one else (favourite Poolaris line)I will ask them If Ican use their computer and here it is Gonzo!!

    Cheers
    Bernie

  9. #9
    SeaLion's Avatar
    Join Date
    Aug 2006
    Location
    Ride Mohave To Havasu. Live In Los Angeles.
    Posts
    841
    What sucks is that the repair bill is way more on the so called superior reliability 4 strokes. I wonder what changed in 06 as far as the Kawis are concerned? The rental co I bought my 12F from had nothing but praise for them but they were all 03 models and high hours. Mine had about 490 hours on it when I bought it. Granted I only paid $800 for it and got all their spare brand new oem parts that are worth more than $800 thrown in. The ski still ran but needed a new pump wear ring, impeller and a valve clearance adjustment. I got a brand new take off whole pump for $200 from Macc Racing and Kawi-Guy traded me a tuned Skat impeller for a brand new steering cable that I got in my deal. The valve clearance adjustment was $200 so for $400 extra I had a good running 3 seater.

    I think the ecu did change for the newer models? Maybe that is the issue or the cause of the failures?
    Last edited by SeaLion; 03-05-2007 at 12:06 PM.

  10. #10
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Damn z, that was a KILLER deal on your 12. I wouldn't mind something like that and then leave it stock.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oh Dear!
    By pauladave in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 07-30-2008, 05:11 AM
  2. Oh dear !
    By Bernie in forum Polaris Open Discussion
    Replies: 8
    Last Post: 09-11-2006, 07:30 PM
  3. Man, Tight fit RRic plumbing and 4in intake!Oh yea SCer back
    By Water4fire in forum 4-Tec Performance
    Replies: 19
    Last Post: 05-02-2006, 05:10 PM
  4. oh shit my engine
    By stickem in forum 4-Tec Performance
    Replies: 35
    Last Post: 03-14-2006, 06:10 PM
  5. OH SHIT! I flipped my RXP!
    By Green Hulk in forum Shops, Tools and Tricks
    Replies: 27
    Last Post: 03-02-2006, 04:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •