Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    2000 virage runs but wont break 5mph

    Just picked up a 2000 virage I was told it wasn't running right so I got it for next to nothing with a 96 xp on a double trailer. I took it to the river and it fired up and seem to run fine motor wise but it (for lack of a better way of putting things) just blows bubbles it takes everything the motor has to run just a few mph. I have a friend who recommends looking at the floating bearing and hopefully this weekend I will have the time to tear into it. If anyone has any other recommendations let me know thanks in advance.


  2. #2
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Does the motor rev at all? what do you mean floating bearing? The thru hull prop shaft bearing ? Stator bearing? Blows bubbles? need a little more info, a video is always good also.

  3. #3
    Quote Originally Posted by Keddano View Post
    Does the motor rev at all? what do you mean floating bearing? The thru hull prop shaft bearing ? Stator bearing? Blows bubbles? need a little more info, a video is always good also.
    this is the bearing http://www.ebay.com/itm/170766720982...84.m1423.l2649 he thinks it may be I should have video taped but didn't think of it at the time. When I say blow bubbles that's just it the motor revs fine and sounds good but when I got off and let my friend on when he reved it it looked like water was coming out like a gurgle (no force) just kinda ripples and bubbles like the prop wasn't barely spinning?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    See my signature links for useful info.

    Check the drive line for slipping at the engine coupler or at the impeller splines.

  5. #5
    http://www.ebay.com/itm/Polaris-New-...a5f3ea&vxp=mtr Would the failure of this part limit the speed the craft could achieve?

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by chatcher View Post
    http://www.ebay.com/itm/Polaris-New-...a5f3ea&vxp=mtr Would the failure of this part limit the speed the craft could achieve?
    A worn through-hull bearing assembly (bad seals) would ventilate the jet pump with air and limit acceleration but normally even a badly worn unit will still manage to get going and get on plane.

    Check the bonded rubber engine coupler and driveline splines for slippage.

  7. #7
    sorry I think I was typing while you were posting is this the dl coupler I linked in my previous?

    Quote Originally Posted by K447 View Post
    See my signature links for useful info.

    Check the drive line for slipping at the engine coupler or at the impeller splines.

  8. #8

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    You linked to a driveshaft through-hull bearing assembly, not a drive coupler.
    Quote Originally Posted by chatcher View Post
    sorry I think I was typing while you were posting is this the dl coupler I linked in my previous?

    Quote Originally Posted by K447 View Post
    See my signature links for useful info.

    Check the drive line for slipping at the engine coupler or at the impeller splines.

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by chatcher View Post
    http://www.partsland.com/index.cgi?N...E-DRIVE-SYSTEM what #? thanks so much for your time
    1 is the drive coupler on the engine.

    6 is the driveshaft itself, which has splines on both ends.

    And the impeller nose also has splines inside.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Virage runs great for 20 min
    By norrislakejunky in forum Polaris Open Discussion
    Replies: 50
    Last Post: 08-30-2013, 07:41 PM
  2. 07 gti runs but wont move
    By lea in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-30-2011, 10:13 PM
  3. 2000 Virage runs-then locks
    By polaris 750SL in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-19-2011, 01:30 PM
  4. '96 Polaris SLX 780 Runs but wont shut off, other...
    By campsmith in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-27-2010, 07:57 PM
  5. 2000 xp clicks but wont turn over
    By lostinilm in forum 2-Stroke Performance
    Replies: 18
    Last Post: 02-11-2009, 12:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •