Results 1 to 5 of 5
  1. #1
    njrealtor55's Avatar
    Join Date
    Dec 2006
    Location
    Flemington, NJ
    Posts
    156
    +1
    2

    rx low rpms - white pipe/rinaldi/skat pump

    got my rx together and it is short/loosing rpms. I have about 3-4 gallons run through it, so it may not be broken in 100%, but it should be close enough.

    it pulls great & has great throttle response, but the top end rpms just are not there. i pulled the trim rings in the skat nozzles and it pickup up 100 rpm, but it is still low (around 6900/6850) as i feel it should be hitting the rev limiter with the mods i have. It pulls about 7,000 when you hit it, but then drops to about 6900/6850 and stays there. I still have to measure the squish and compression (maybe tonight, i have been lazy).

    i'm not sure on the impeller pitch (16/23 swirl) or what size rings should be in it. Skat calls for a 13/19 for the rx, but that is in a stock pump. I guess there may be a possibility the pipe is leaking internally - i can pull the rear rave to check.

    i have yet to install my rossier head w/ 49cc domes, mt race case (bump the rev limiter and turn up the timing) - but i wanted to make sure it ran good before i did all that.

    mods:
    white pipe & manifold (hard jetted 120)
    rxx water box (no water regulator, drill and tapped a fitting & hard jetted 160)
    rinaldi reeds
    miller reed spacers
    lightened mag flywheel
    lightened pto flywheel
    drilled rave valves
    stock head (thin layer of oem head hasket removed)
    3 hole base gasket
    148mm 12 vein pump
    16/23 skat swirl
    82/85 nozzle rings
    rxx flame arrestor
    160 hs (1/2 out)
    100 ls (2 out)
    chokes out


  2. #2

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    get rid of your RXX water box and run the water regulator, do not install the junk micro torch.

  3. #3
    njrealtor55's Avatar
    Join Date
    Dec 2006
    Location
    Flemington, NJ
    Posts
    156
    +1
    2
    rxx waterbox is an untapped 951di waterbox which is supposed to be better than a 951 stock box. whats wrong with the MT? I emailed Tim @ novitech and he took a while to respond that he still does the remap - but by then i pulled the trigger and bought the race case from wayne.

  4. #4
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    Jetting is rich and prop too tall.
    Run the stock regulator as mentioned
    What is your pop off ? and what size Needle and seat are you using ?

  5. #5
    m schmidt's Avatar
    Join Date
    Mar 2007
    Location
    East, Tn.
    Posts
    235
    +1
    2
    Quote Originally Posted by jim View Post
    get rid of your RXX water box and run the water regulator, do not install the junk micro torch.
    + 1

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Low RPMs 7500 after installing Walbro pump
    By Snoman in forum 4-Tec Performance
    Replies: 191
    Last Post: 04-21-2011, 07:22 AM
  2. Replies: 6
    Last Post: 10-29-2008, 11:53 PM
  3. Low RPM Issue
    By xenonx in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-19-2006, 03:19 PM
  4. Jerry...this must be your Skat-Pump?
    By MTD03sc in forum 4-Tec Performance
    Replies: 15
    Last Post: 04-20-2006, 08:05 AM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •