Results 1 to 9 of 9

Thread: Need help

  1. #1

    Need help

    I was out riding my 1993 Kawasaki 750sx and after a while it suddenly started losing power so I cut the engine and paddled in. When I pulled the hood up I discovered water and exhaust smoke in the engine bay. I checked the hose running to the water box because that seemed where the water and exhaust was coming from and there was no issue. I am thinking that the water box is cracked and leaking water and exhaust. Does that sound correct or does anyone have other possible suggestions?


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Why did you ask this same question so many times?

    No help for you!

  3. #3
    showmepro1200's Avatar
    Join Date
    Sep 2006
    Location
    Jefferson City MO (Ride at Lake of the Ozarks)
    Posts
    524
    +1
    40
    Kinda rough on a newbie there, Steve.

  4. #4
    Yeah, I already said that was my mistake and didn't realize that it would post like it did.

  5. #5
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Quote Originally Posted by showmepro1200 View Post
    Kinda rough on a newbie there, Steve.
    Yea, good thing I'm not a moderator on this board. I moderate another board where I can take more drastic action.

    Go ahead and help him!

  6. #6
    showmepro1200's Avatar
    Join Date
    Sep 2006
    Location
    Jefferson City MO (Ride at Lake of the Ozarks)
    Posts
    524
    +1
    40
    Quote Originally Posted by steve45 View Post
    Quote Originally Posted by showmepro1200 View Post
    Kinda rough on a newbie there, Steve.
    Yea, good thing I'm not a moderator on this board. I moderate another board where I can take more drastic action.

    Go ahead and help him!
    I did. Be a nice guy, dude. You were a newbie once too.
    Last edited by showmepro1200; 07-05-2013 at 08:18 AM.

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    I AM a nice guy. I've tried to help dozens, if not hundreds of people here. But when this clown comes on and asks the same question all over the board, that's uncalled for. That's the kind of crap they have on that 'other' PWC site where the children hang out.

  8. #8
    showmepro1200's Avatar
    Join Date
    Sep 2006
    Location
    Jefferson City MO (Ride at Lake of the Ozarks)
    Posts
    524
    +1
    40
    Lighten up, Francis Not like its the first person that's ever done it. In fact, you took the time and bandwidth space to respond to each and every one of the guys postings to say "No help for you!!" thereby perpetuating the thread instead of just letting it go. Think about it.

    He's not a clown, he's a newbie, he got the point on my response and said he was sorry. Done.

  9. #9
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Whatever!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new 05 RXT NEED HELP
    By RXPNJ in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-03-2009, 12:16 PM
  2. NEED HELP URGENT(HULK) RXP DOWN
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM
  3. My 2 RXP's need HELP!
    By Tube Master in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-19-2005, 09:44 PM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •