Results 1 to 10 of 10

Thread: Need help

  1. #1

    Need help

    I was out riding my 1993 Kawasaki 750sx and after a while it suddenly started losing power so I cut the engine and paddled in. When I pulled the hood up I discovered water and exhaust smoke in the engine bay. I checked the hose running to the water box because that seemed where the water and exhaust was coming from and there was no issue. I am thinking that the water box is cracked and leaking water and exhaust. Does that sound correct or does anyone have other possible suggestions?


  2. #2
    showmepro1200's Avatar
    Join Date
    Sep 2006
    Location
    Jefferson City MO (Ride at Lake of the Ozarks)
    Posts
    524
    +1
    40
    Check for a split exhaust hose while you're in there too.

    By the way, I would guess most folks on the site simply click on new postings, not just a specific thread. So when you post your same inquiry 5 or more times, it gets a bit aggravating

  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    Agreed! Posting so many times is downright rude. No help for you!

  4. #4
    My bad, just really needed some help and wasn't aware that it would be seen so many times. Just need help.

  5. #5
    showmepro1200's Avatar
    Join Date
    Sep 2006
    Location
    Jefferson City MO (Ride at Lake of the Ozarks)
    Posts
    524
    +1
    40
    I think you're on the right track, since you found exhaust smoke. Find the split hose or broken clamp, or split waterbox, whatever is wrong on the exhaust system.

    If it runs better after you took the hood off you were for sure getting exhaust in the engine compartment and choking out the motor with 'bad air'.

  6. #6
    Thank you, I'll check the water box and all the hoses/clamps going to it.

  7. #7
    showmepro1200's Avatar
    Join Date
    Sep 2006
    Location
    Jefferson City MO (Ride at Lake of the Ozarks)
    Posts
    524
    +1
    40
    any luck??

  8. #8
    Haven't been able to get to it, I will keep you posted

  9. #9
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511
    Easiest way to check if you trailer it is leave it tied on and back it in the water a bit and fire it up. If not near water try it on the hose. Make sure and start the ski first, then crack the hose on, and hose off before stopping ski. These other folks also have you in the right direction for sure. Good luck.

  10. #10
    So it turned out that the water box is cracked. The crack was real clean right on the seam so I sealed it and I'll see if that works. Trying to avoid buying a new one for $200.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new 05 RXT NEED HELP
    By RXPNJ in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-03-2009, 12:16 PM
  2. NEED HELP URGENT(HULK) RXP DOWN
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM
  3. My 2 RXP's need HELP!
    By Tube Master in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-19-2005, 09:44 PM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •