Results 1 to 7 of 7

Thread: Not Startin

  1. #1
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299

    Not Startin

    i didnt start my waverunnre for a week and i went today and start it...it did want to start..the battery is new. what can b the problem...the relay is good. it rolls for a secnd and thats it


  2. #2
    Water Bum Rodneyae's Avatar
    Join Date
    Dec 2006
    Location
    Roanoke, Va
    Posts
    3,083
    Charge battery, check wires for corsion. Look at the gound wire where it bolts to the engine very closely.

  3. #3
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299
    cana swollen housing stop the engine frmo starting?

  4. #4
    DAGO RACING CREW 97GPSLEEPER's Avatar
    Join Date
    Apr 2006
    Location
    Orange, TX
    Posts
    4,228
    +1
    169
    Do you mean the impeller is stuck in the housing? It would still turn over, it may even start depending on how stuck the impeller is in the housing.

  5. #5

    Join Date
    Dec 2005
    Location
    Beaufort, SC
    Posts
    119
    A swelled impeller housing/liner can stop it from turning over. My buddy is replacing one right now that did that. He pulled the head off first (2000 GPR) thinking the engine was locked up, only to find out that it was the impeller housing.

    His was sitting up for the winter though (several months) and not just one week.

  6. #6
    fastkaz's Avatar
    Join Date
    Jan 2007
    Location
    Cayman Islands/Orlando Fl
    Posts
    299
    the engine rolls for a second but doesnt start...

  7. #7
    DAGO RACING CREW 97GPSLEEPER's Avatar
    Join Date
    Apr 2006
    Location
    Orange, TX
    Posts
    4,228
    +1
    169
    Take the spark plugs out and try and roll the motor over by hand. You can grab the couplers and try to roll it over. If it rolls over by hand with the spark plugs out, it is probably not your impeller housing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What not to do with your RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 60
    Last Post: 01-14-2010, 10:20 PM
  2. To mod or not to mod?
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 27
    Last Post: 01-11-2006, 02:58 PM
  3. State Farm NOT the RXP
    By rx4pain in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 05-27-2005, 08:25 PM
  4. Not much talk about Speed Venturi?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-14-2005, 07:47 AM
  5. First time out with stage 1 05 RXP Not happy.
    By Fastcat in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-10-2005, 09:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •