Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    Join Date
    Jun 2013
    Location
    Central Alabama
    Posts
    31

    What do I have here? A cover up?

    Buddy has two 03 GTXs. And I know this guy and he has no clue about anything mechanical and truely does not know what he has. One is b/c these skis came from wife's previous marriage. He claims one is a SC one is not. One ski has side decals and SC decals. One does not. They have been setting up for a couple years. I told him if he bought the gas and batteries I would get them running and check them out.

    Ski 1 - Non SC - 130 hrs. No codes - Open engine compartment there is a SC. Both have a red SC. Where factory stock SCs red in 03? Oil level ok, looked ok no foul smell. Plugs ok. Checked compression - 120, 122.5, 125.. Installed batteries and fuel. Cranked after several turns. Seems to run ok. Throttle response not great. Have to really apply throttle to get RPMs up. Not snappy I guess. Ran for 3-4 minutes.

    Heres my concern. Noticed wire harness not quite installed correctly. Some things just did not look right about it. I checked the oil level again be fore I closed it up. Oil level was about 1.5-2" above full mark. Way up on stick. I checked it repeatedly while I worked on other ski and it stayed up high above full mark.

    Noticed pump was missing a rear bracket that other ski has. Also noticed rubber looking o-ring or gasket sticking out in pump housing and part actually is between impeller and wear ring. See pics.

    My guess is this ski has had past problems may have had a hatchet mechanic working on it. IE. Both batteries had been replaced before and neither were bolted down. Battery terminals were severely corroded.

    Ski 2 - w/ SC - 70 hrs - No codes - Checked out same as above. Compression 124, 122.5, 1225. Engine compartment seemed more in order. Did notice spark plugs were not torqued in?? Red SC? Fired it up, seems to run and sound good. Has real good throttle response. Got snap to it. Kinda like my 03 RXTs.

    Cover up theory: Not sure if his wife was original owner. But I'm wondering if someone intentional removed the side decals and the SC decals. And sold or passed on as one as non-SC. Possibly b/c the SC is gone out and performance is half that of the other ski? Ceramic washer are probably gone and has blocked up lubrication passages and thus oil not circulating properly and causing the high oil level?

    Ski 2 - Only 70 hours? Half of the sister ski. My thought was this ski was broke down first and laid up while other was being used.

    How risky is this buy? Or what should I offer? Or the better question, what is the salvage value if I was to piece together or part out the two skis?

    Click image for larger version. 

Name:	SKI2_Bracket.jpg 
Views:	131 
Size:	57.9 KB 
ID:	305583Click image for larger version. 

Name:	SKI1_No Bracket.jpg 
Views:	120 
Size:	52.3 KB 
ID:	305584Click image for larger version. 

Name:	SKI1_Oring_Gasket.jpg 
Views:	152 
Size:	34.5 KB 
ID:	305585Click image for larger version. 

Name:	SKI2_Impeller_Oring.jpg 
Views:	122 
Size:	41.1 KB 
ID:	305586Click image for larger version. 

Name:	SKI1_Engine.jpg 
Views:	134 
Size:	93.0 KB 
ID:	305587

    BF


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Pull the chargers and look at the washers.
    It's not hard.
    If the washers are gone its time to rebuild the motor or Atleast pull it and clean it out.

    Too many possible issues with broken washers.
    That skis value is only for parts if the washers are gone.
    Or pull the charger hose and try to spin the insides.
    If it spins freely then they are gone.
    Yeah sounds like a cover up...

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    When skis sit they start breaking down a lot when you get them going again...
    Good luck!!!

  4. #4
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    The earlier chargers were red with yellow valve covers on the engines. The earlier 185 sc also did not have clutch washers. the clutch worked slightly different so when it wore out, there was nothing that fell in the motor. best way to check charger condition is to remove it though. both machines are originall 185 machines though or it wouldn't have had that bracket in the back that is bolted to the hull. if they are both yellow, they also did not make a yellow N/A ski I believe

  5. +1 by:


  6. #5
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    Also, the rubber in the pump is the wear ring. they are plastic with a rubber coating. the coating wears out and then rips off

  7. #6
    Ditto above, the 03's will not have the washers if the chargers are stock. Also, if the original plastic pump was switched to a metal one, ther bracket is no longer needed. Some plastic pumps were replaced under warranty with the metal ones due to flexing issues.

  8. #7

    Join Date
    Jun 2013
    Location
    Central Alabama
    Posts
    31
    Found out today wife said skis were bought used. Did not know who worked on them. What about the high oil level after running 3-4 minutes?

  9. #8

    Join Date
    Jun 2013
    Location
    Central Alabama
    Posts
    31
    Quote Originally Posted by 8 is enough View Post
    Also, if the original plastic pump was switched to a metal one, ther bracket is no longer needed. Some plastic pumps were replaced under warranty with the metal ones due to flexing issues.
    I'll check again. But I'm sure both were plastic pumps.

    BF

  10. #9

    Join Date
    Jun 2013
    Location
    Central Alabama
    Posts
    31
    Quote Originally Posted by GGG View Post
    Also, the rubber in the pump is the wear ring. they are plastic with a rubber coating. the coating wears out and then rips off

    So I'm assuming w/ the rubber visibly coming off it is time to replace wear ring? The other ski appears to have a white wear ring. Or is that a what it looks like w/ the rubber completely gone?

    Both pumps are plastic. Also, both have same vehicle decal below. I believe these are identical skis. I'm thinking my buddy thinks one is a non-SC ski because decals have been removed.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Decal_No Decals.jpg 
Views:	71 
Size:	71.1 KB 
ID:	305725   Click image for larger version. 

Name:	IMAG0225.jpg 
Views:	67 
Size:	40.0 KB 
ID:	305726  

  11. #10
    mattydipps's Avatar
    Join Date
    Mar 2013
    Location
    Babylon, Long Island
    Posts
    652
    +1
    51
    Quote Originally Posted by Blueforester View Post
    Found out today wife said skis were bought used. Did not know who worked on them. What about the high oil level after running 3-4 minutes?
    a high oil level could be the reason your throttle isnt crisp..

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What grate do I have here?
    By bowsniper in forum Polaris Open Discussion
    Replies: 10
    Last Post: 10-21-2009, 11:19 AM
  2. stand up ski's what do you have
    By mr_3_0_5 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 21
    Last Post: 04-01-2009, 09:02 PM
  3. What do you have for audio on your pwc?
    By spaulding in forum Open Discussion
    Replies: 2
    Last Post: 03-02-2008, 10:55 PM
  4. what do i have 2 do 2 bring her back in the season easy ?
    By Bone1050 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 01-25-2007, 07:48 PM
  5. sponsons what do you have????
    By Knr in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 05-09-2006, 08:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •