Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Jan 2007
    Location
    JEDDAH
    Posts
    213

    Angry S/C Riva & Rotex Racing

    Me and my friends replaced the two impellers

    I have installed the Riva's impeller & my friend

    installed the Rotax Racing Impeller , but when

    we spine the S/C from the rod ( back of the s/c )

    after we fixed the Jerry's washers & ceramic bearing

    and we fully tighted the hole s/c to be ready to install

    it in the jet ski , we found my Riva s/c is heavier than

    his Rotax racing ( when we rotated by hand ) ,

    ( Riva is slight heavy & Rotax Racing is very very soft )

    pl, tell me what to do , are they okay or not , fyi we applayed

    the red locitte between the two faces of the s/c before

    we installed it , Thanx
    Last edited by LAB69; 03-04-2007 at 06:02 PM.


  2. #2
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    I hope that it wasn't red thread locking compound that you put on the halves of the SC...

  3. #3

    Join Date
    Jan 2007
    Location
    JEDDAH
    Posts
    213
    Quote Originally Posted by GTXX View Post
    I hope that it wasn't red thread locking compound that you put on the halves of the SC...
    YEP I PUT THE RED LOCK IN THE EDGE ONLY OF THE HOUSING

    NOTHING ELESE , THEN WHAT DO U THINK, THANX

  4. #4
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,809
    If it were me I would separate the the housing and take a look at the installation of the bearings again. It is going to be very hard to tell what may be wrong if there is no obvious problem on the outside. Just by you explaining there is a lot of tension would definately stop me from installing that thing and then running it. Supercharger failure can destroy a motor and it would be a whole lot easier just to take a look at everything one more time.

  5. #5
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,762
    +1
    29
    I used RTV between the 2 SC halves.

  6. #6

    Join Date
    Jan 2007
    Location
    JEDDAH
    Posts
    213
    Quote Originally Posted by Red Devil View Post
    If it were me I would separate the the housing and take a look at the installation of the bearings again. It is going to be very hard to tell what may be wrong if there is no obvious problem on the outside. Just by you explaining there is a lot of tension would definately stop me from installing that thing and then running it. Supercharger failure can destroy a motor and it would be a whole lot easier just to take a look at everything one more time.
    OKAY , THEN I WILL DO IT , THANXXXXXXXXXXXXXXX

  7. #7

    Join Date
    Jan 2007
    Location
    JEDDAH
    Posts
    213
    Quote Originally Posted by HOSS View Post
    I used RTV between the 2 SC halves.
    WHAT DO U MEAN ABOUT THE RTV ( IS THAT THE TRIM ) !!!

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by LAB69 View Post
    YEP I PUT THE RED LOCK IN THE EDGE ONLY OF THE HOUSING

    NOTHING ELESE , THEN WHAT DO U THINK, THANX
    I think you made a huge mistake. You do not put red loc tite between the two case halves. You are supposed to use a light film of silicone.

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by LAB69 View Post
    we found my Riva s/c is harder to turn than

    his Rotax racing ( when we rotated by hand ) ,

    Did you forget to install the spool piece that goes on the shaft between the two bearings? On 06 spec shaft assembly's there is also a washer that goes between the rear bearing and spool piece.

  10. #10

    Join Date
    Jan 2007
    Location
    JEDDAH
    Posts
    213
    Quote Originally Posted by Green Hulk View Post
    Did you forget to install the spool piece that goes on the shaft between the two bearings? On 06 spec shaft assembly's there is also a washer that goes between the rear bearing and spool piece.
    THE SEADOO DEALER FIXED THAT TOTALLY , HE

    TOLD ME NORMAL , BUT , I CAN FEEL THE DIFFERENCE

    BETWEEN RIVA'S & ROTAX S/C ( ME & ADNAN )

    MINE IS SLIGHT HEAVIER THAT ADNAN'S S/C

    WHEN I TURN IT BY HAND, THANX

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. seadoo rxp o5 riva or rotax racing ecu and 50lb injectors
    By pwc guru in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 05-05-2008, 08:58 AM
  2. 2006 GPR w/Riva EFI and Race Filter
    By yardsale in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 06-10-2007, 06:18 PM
  3. HELP Rotex Racing IC installation
    By BlackHawk in forum 4-Tec Performance
    Replies: 4
    Last Post: 11-10-2006, 09:32 AM
  4. Riva vs Rotax Racing kits which to use ?
    By stonylake rxp in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-24-2006, 10:28 AM
  5. Rotex Racing ECU instalation problem
    By 4-techscharger in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-02-2006, 08:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •