Page 1 of 35 1 2 3 11 ... LastLast
Results 1 to 10 of 343
  1. #1
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6

    New motor going in my Pro 785.

    So, here we go.


  2. #2
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    Here's the engine. It painted it red mettalic. Everything is torqued to spec and ready. Cases have new sealant. All new seals on the crank. Crank is new.rods pistone stator ete all new. Timing marks were verified.turns over by hand with lots of hiss when the pistons go tdc. Tight. But smooth.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20130704_140426.jpg 
Views:	181 
Size:	104.3 KB 
ID:	305694  

  3. #3
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    Making good progress. Its all disconnected except the mag cylinder front lower head pipe bolt. What a pain to get that out. I had 1 petal on the reeds that was chipped. Another petal is suspect.

    I have a good set of reeds all tight and not chipped.to go in this engine. They are going to be stock reeds with the stuffers.
    .
    When taking the pump off, I can hear 1 of the bearing is shot.rough sounding when spun. Prop has minor edge issues.I can clean that up does anyone has 1 beRing laying around for the pump? Let me know. I may swap the slx's pump.
    Last edited by K447; 07-05-2013 at 06:56 AM. Reason: Petals

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,598
    +1
    1,276
    Replace both bearings in the jet pump, and new seals too. No point in risking a bearing failure somewhere down the road, with all the damage that can cause.

  5. #5
    RizzO
    Join Date
    Aug 2008
    Location
    Milwaukee, Wisconsin
    Posts
    300
    +1
    1
    Nice job on paint, looks sharp.

    RiZ

  6. #6
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    Thax Riz.. hmmm. Probably a good idea Keith. You. Caught me being. Cheap. Busted. Do it right or not at all. Your right. If the other bearing goes, it cohld.destroy the pro and stub shaft in there. Not to mention the wear ring or prop.

    By the way, do all 785 motors have allen head bolts.for the head pipes EXCEPT. The Mag head pipe? I have 3 allens and 1 hex bolt

  7. #7
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    The allen bolt is located on the bottom forward location? That bolt is very hard to access and I had to make a small tool to get in there. What. A Pain. But its out.now. hooray! Tomm the new motor.goes in.

    Here's a picture of the bolt and the tool I made. Worked good.

  8. #8
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    The allen bolt is located on the bottom forward location? That bolt is very hard to access and I had to make a small tool to get in there. What. A Pain. But its out.now. hooray! Tomm the new motor.goes in.

    Here's a picture of the bolt and the tool I made. Worked good.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20130706_203825.jpg 
Views:	84 
Size:	48.9 KB 
ID:	305845  

  9. #9
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    .

  10. #10
    You shouldn't need to take that bolt all the way out... the manifold and gasket should be slotted...just loosen slightly and remove the rest if the bolts...manifold should slide off.

Page 1 of 35 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My "new" Sharp's Marine 1010 Pro 785
    By hyoctane23 in forum Polaris Projects
    Replies: 624
    Last Post: 11-24-2017, 03:14 AM
  2. break in on my pro 785 and only like half burning on the center cyl
    By wayneb2510 in forum Polaris PWC Performance
    Replies: 69
    Last Post: 07-09-2013, 08:32 AM
  3. Sad day for my Pro 785, maybe a build in the future!
    By Kerminator in forum Polaris How To & FAQs
    Replies: 32
    Last Post: 07-01-2011, 06:23 AM
  4. no spark in my pro 785
    By joshxp in forum Polaris PWC Performance
    Replies: 2
    Last Post: 01-22-2008, 02:11 AM
  5. New cylinder screech/scrape?? (97 Pro 785)
    By WIslxer in forum Polaris PWC Performance
    Replies: 11
    Last Post: 09-28-2007, 01:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •