Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    The Bad of Charging Battery while Still Connected to the Machine?

    What problems can you experience when charging your Sea-Doo with a battery charger and having the battery still connected to the machine (when your not suppose to)?

    I have replaced my regulator/rectifier and starter solenoid and purple 3 amp fuse in the electrical box and I am still experiencing problems with my Sea-Doo I am guessing it could be the MPEM? What else could I replace?? hmm


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    That's why you don't charge it with the leads connected.
    Yes the ecu is probably fried.
    Find another 1 and swap it in before you drop a $1000 on a new 1 and find out that wasn't it.
    Good luck.
    That's an expensive lesson to learn..

  3. #3
    Quote Originally Posted by wotxxxsd View Post
    That's why you don't charge it with the leads connected.
    Yes the ecu is probably fried.
    Find another 1 and swap it in before you drop a $1000 on a new 1 and find out that wasn't it.
    Good luck.
    That's an expensive lesson to learn..
    So that means I can't boost my Sea-Doo if my battery dies?

    You would think there is some sort of electrical protection to the MPEM. I could see if I crossed my wires that it would wreck it.

  4. #4

    Join Date
    Jun 2008
    Location
    Lake Conroe (Montgomery,) Texas
    Posts
    417
    +1
    10
    This is a cut and paste from the 1996 Sea Doo Shop Manual:

    Removal
    WARNING : Battery BLACK negative cable
    must always be disconnected first and
    connected last. Never charge or boost battery
    while installed in watercraft.


    I'm not sure if yours is the same but I would guess that it is.

  5. #5
    Ya I did a couple more tests, I believe its the MPEM that is pooched.

    Does anyone know if this MPEM will work on my ski (2004 Sea-Doo XP DI)? Just making sure my ski is 951 too, but the MPEM seems to be made in year 2000, when mine was made in 2004. :/
    http://www.ebay.com/itm/Sea-Doo-951-...39754a&vxp=mtr

  6. #6
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Not sure if that will work but personally I never buy anything used that has been in a salty machine or from any place that is near salt water... Never know what it came from or what level of corrosion me be inside it

  7. #7
    Charging while connected is one quick way to fry that MPEM. Worse than doing by a running vehicle which is also bad lol.

  8. #8
    dlajoy1122's Avatar
    Join Date
    Jul 2013
    Location
    Windsor, Ontario, Canada
    Posts
    93
    Wow I am glad I came upon this thread. I always charge my battery while hooked up to my seadoo. I have a top of the line fully automatic charger I paid a lot for an it always tops it off and then leaves it on a light charge which is maintenance mode. My seadoo is still working though. Good thing I didnt from my MPEM.

  9. #9

    Join Date
    May 2012
    Location
    McKinney Texas
    Posts
    140
    +1
    5
    I find it hard to believe that the makers would not have included a 2 dollar chip that will output a clean 12v from any input up to 35 volts.

  10. #10
    dlajoy1122's Avatar
    Join Date
    Jul 2013
    Location
    Windsor, Ontario, Canada
    Posts
    93
    Quote Originally Posted by keithg1964 View Post
    I find it hard to believe that the makers would not have included a 2 dollar chip that will output a clean 12v from any input up to 35 volts.
    That would make sense though. I've had my 96xp for the 2nd season now and the entire first season I charged my battery while it was hooked up in the seadoo with no problems.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is the Waverunner's flywheel magneto capable of charging an AGM battery??
    By njjoe in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-06-2011, 09:46 PM
  2. Charging battery (while installed on ski)
    By Tontsa80 in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-08-2011, 08:30 AM
  3. Charging Battery while connected inside the waverunner
    By WtrGrl in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 05-06-2011, 05:03 PM
  4. Anyone have a set of seadoo battery straps they want to get rid of?
    By 951ccshoe04 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-02-2010, 11:18 PM
  5. Not too bad of a day at the lake......
    By camar0 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-23-2007, 11:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •