Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 40
  1. #1
    JohnCiccarelli's Avatar
    Join Date
    Oct 2008
    Location
    Bay Tree Lakes, NC
    Posts
    292

    2008 RXT-X Slow top Speed

    The top speed is only 62 MPH. Shouldn't it be closer to 70? I had another one of these skis a couple years ago and it topped out at 68.

    The Max RPM is 8140. Is there anything except the impeller that could cause this.

    Any Ideas, John


  2. #2
    SELF27's Avatar
    Join Date
    May 2013
    Location
    Austin, TX
    Posts
    202
    +1
    16
    Wear ring to impellor clearance or damaged impellor.

  3. #3
    JohnCiccarelli's Avatar
    Join Date
    Oct 2008
    Location
    Bay Tree Lakes, NC
    Posts
    292
    Quote Originally Posted by SELF27 View Post
    Wear ring to impellor clearance or damaged impellor.
    That is what I am thinking except I don't think that the wear ring has much effect on top speed. I know it affects acceleration and cavitation.

  4. #4
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    A damaged or worn wear ring will cost you speed. The wear ring and impeller would be the first things I would check based on what you listed.

  5. #5
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Wear ring to impeller clearance to high equals loss of thrust and speed and accel.

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    How are you measuring your speed?
    Your rpms sound fine.

  7. #7
    JohnCiccarelli's Avatar
    Join Date
    Oct 2008
    Location
    Bay Tree Lakes, NC
    Posts
    292
    Quote Originally Posted by troyheb View Post
    How are you measuring your speed?
    Your rpms sound fine.
    I took the GPS out and it looks like the Speedometer reads 3 MPH High. So the top speed is only 59.

  8. #8
    JohnCiccarelli's Avatar
    Join Date
    Oct 2008
    Location
    Bay Tree Lakes, NC
    Posts
    292
    I guess I am going to order a new Impeller and Wear Ring. The chart that I have says that the 2008 RXT-X should use a 14/19 Solas Concord. It says 15/21 for the 2009 RXT-X 260. Everywhere I read people seem to be using 15/21 or 15/22. My ski is stock and I do not plan on any Major Mods. Would I be OK with a 15/21. In the end I hope to get near 70 MPH.

    Thanks for any advice, John

  9. #9
    cjo632racing's Avatar
    Join Date
    Sep 2008
    Location
    Ocala Fl.
    Posts
    191
    +1
    3
    A 15-22 will be to much prop. Go with the 14-19

  10. #10

    Join Date
    Feb 2013
    Location
    Michigan
    Posts
    13
    I have a stock 08 RXT 215 and it runs 66 MPH on GPS. Before buying a new impeller, you might check it out. You might be able to just replace the wear ring and have the impeller blades pitch reset.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vx110 2008 under performing at top speed after new impeller
    By Happy days in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 07-27-2013, 04:58 AM
  2. 05 RXT no power/top speed 43 mph
    By wolverine350r in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 10-15-2011, 06:57 PM
  3. Gpr Bad prop spin And slow top speed!!!!!!
    By Monster Machine in forum Yamaha PWC Performance (2-stroke)
    Replies: 23
    Last Post: 06-19-2011, 04:40 PM
  4. slow top speed please help
    By slydogge in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 08-17-2010, 02:29 PM
  5. 2007 rxt not getting top speed please help
    By jamesrini79 in forum 4-Tec Performance
    Replies: 26
    Last Post: 08-10-2007, 08:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •