Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 37
  1. #1
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598

    Another Broken SOLAS impeller.....

    broke another SOLAS concord impeller yesterday on the SJR, this time i was just cruising about 40mph (the last one i was doing a speed run) when the ski lost power and started shaking badly, at anything above 2000rpm i knew what it was right away and limped back to the ramp, about a 1/2 mile. am i the only one blowing impellers on a NA powered ski ?????? as you can see, it broker at the blade, not the root like the last one. and the funky cut/grove on the broken blade is where it was cutting my transom plate, need a transom plate now too, sold the one i had.....

    Click image for larger version. 

Name:	solas impeller 002.JPG 
Views:	299 
Size:	194.5 KB 
ID:	305863Click image for larger version. 

Name:	solas impeller 004.JPG 
Views:	306 
Size:	193.6 KB 
ID:	305864
    Click image for larger version. 

Name:	solas impeller 006.JPG 
Views:	302 
Size:	189.3 KB 
ID:	305865Click image for larger version. 

Name:	solas impeller 007.JPG 
Views:	292 
Size:	200.0 KB 
ID:	305866
    Last edited by big john; 07-07-2013 at 09:42 AM.


  2. #2
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    I think I have seen two other VXRs that have broken Solas props. That's why I've stuck with Skat so far. I've liked Solas on other skis, but scared to invest in them for this model for this reason.

  3. #3
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    i put a skat 12/17 back in it yesterday and it will barley spin 7600 rpm, i didnt have my gps with me to see what speed i was getting

  4. #4
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    I'm running a Skat 13/16 about 8100 in Texas summer air right now. RPMs and speeds down. Ready for fall.

  5. #5
    Pistonwash's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Posts
    3,595
    +1
    77
    Holy crap...I've never seen a prop get that jacked up unless it ate something like a rock or piece of metal. Have you called Solas about the previous props and what do they say? Seems like they would replace it. I had Skat replace a prop because the finish was tarnished.

  6. #6
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    nothing in the prop, second one to blow, i must have the worlds baddest VXS that wont do over 70 ..............

  7. +1 by:


  8. #7
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Im never putting a solas on my ski.

  9. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    I had a Solas prop in my 08PX do something similar.

    Click image for larger version. 

Name:	DSCN0096.jpg 
Views:	142 
Size:	93.0 KB 
ID:	305888



    Just shitty ass castings.

  10. #9
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    wonder if heat treating them will help out, i have a brand new solas 14/23 twin for my GPRSHO, and i dont what that coming apart at 8800+ rpms !!!

  11. #10
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Quote Originally Posted by big john View Post
    wonder if heat treating them will help out, i have a brand new solas 14/23 twin for my GPRSHO, and i dont what that coming apart at 8800+ rpms !!!

    what about cyrogenics.......freeze the bitch?

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ( 4 broken ) solas impeller tools
    By 305coco in forum Yamaha PWC Performance (4-stroke)
    Replies: 64
    Last Post: 11-02-2016, 12:03 PM
  2. solas impeller, broken blade, while cruising 25mph.
    By dan144k in forum Yamaha Sport Boat
    Replies: 1
    Last Post: 09-06-2016, 08:07 PM
  3. Broken blade on Solas Impeller
    By FasstPhilip in forum Yamaha Open Discussion
    Replies: 23
    Last Post: 06-21-2009, 08:43 PM
  4. For those of you with Solas impellers.............
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-08-2005, 07:49 AM
  5. Replies: 3
    Last Post: 05-06-2005, 02:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •