Results 1 to 10 of 10
  1. #1
    rmk82nd's Avatar
    Join Date
    Apr 2011
    Location
    Charlotte, NC
    Posts
    369
    +1
    4

    2004 rxp won't start

    So new battery is in and getting all the beeps and still does not want to turn over. I have tried starting with connecting the starter relay posts but still just cranks but wont turn over now what? Is it my starter or could it be the spark plugs as wells.


  2. #2
    rmk82nd's Avatar
    Join Date
    Apr 2011
    Location
    Charlotte, NC
    Posts
    369
    +1
    4
    One more update I hear a click by the engine when I put the key in but no fuel pressure shows when key is in on the rrfpr. Is this an issue?

  3. #3
    Banned User
    Join Date
    Aug 2011
    Posts
    5,049
    +1
    238
    How old is battery. Betting bad battery

  4. #4
    rmk82nd's Avatar
    Join Date
    Apr 2011
    Location
    Charlotte, NC
    Posts
    369
    +1
    4
    Brand new just put it in today and bought today.

  5. #5
    Banned User
    Join Date
    Aug 2011
    Posts
    5,049
    +1
    238
    Hmm try solenoid?

  6. #6
    rmk82nd's Avatar
    Join Date
    Apr 2011
    Location
    Charlotte, NC
    Posts
    369
    +1
    4
    Quote Originally Posted by thatdude596 View Post
    Hmm try solenoid?
    Yup that's what I meant by starter relay if thats the thing with 2 red wires connecting by fuse box that i tried to start with a set of pliers and sparks flew and it cranked but did not turn over so what else you got for me lol.

  7. #7
    Banned User
    Join Date
    Aug 2011
    Posts
    5,049
    +1
    238
    Ok so you jumped solenoid and it sparked. So its getting juice. Cranks over but won't start. Wouldn't that mean the starter solenoid is bad? Got new plugs? Good fuel?

  8. #8
    rmk82nd's Avatar
    Join Date
    Apr 2011
    Location
    Charlotte, NC
    Posts
    369
    +1
    4
    Quote Originally Posted by thatdude596 View Post
    Ok so you jumped solenoid and it sparked. So its getting juice. Cranks over but won't start. Wouldn't that mean the starter solenoid is bad? Got new plugs? Good fuel?
    That's what I was asking. Thank you for ensuring it could still be the starter solenoid over the searches I looked it appeared to be the starter. I will order a new solenoid and as far as the plugs they were new last year with 34 hours on them will pick the, up as well. Appreciate the help. Will update and let you know.

  9. #9
    I had the same issue. New battery wouldn't start. Replaced the starter relay and it worked

  10. #10
    rmk82nd's Avatar
    Join Date
    Apr 2011
    Location
    Charlotte, NC
    Posts
    369
    +1
    4
    Quote Originally Posted by RXPTX View Post
    I had the same issue. New battery wouldn't start. Replaced the starter relay and it worked
    K thank you both.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 rxp won't start
    By Dsmjske08 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-06-2014, 02:57 PM
  2. Help - '06 RXP Won't Start
    By Flynfox in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-26-2008, 05:35 PM
  3. '05 RXP won't start please help
    By fleahman in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-24-2008, 10:52 PM
  4. RXP won't start
    By wolftrader in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-07-2008, 10:39 AM
  5. RXP won't start!
    By rxpblast in forum 4-Tec Performance
    Replies: 15
    Last Post: 07-12-2005, 03:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •