Results 1 to 3 of 3
  1. #1

    Join Date
    Aug 2012
    Location
    Pennsylvania
    Posts
    17

    2005 GTI LE-RFI Rear Cylinder Problem

    It was running fine, and then just went into limp mode with the maintenance light on. Got it back to the dock, and noticed that the rear cylinder wasn't firing since there was wet residue on the spark plug. I put new plugs it, it ran fine for about 40 minutes and then the same thing. Got it back to the dock and again the rear cylinder wasn't firing. I switched the plugs around and the rear cylinder still will not run. I checked to see if it had spark and it does, but it appears that it may be slightly un-normal. I'm not sure if the RFI have injectors that could be clogged or if it definitely is the coil pack. Any suggestions would be greatly appreciated.


  2. #2
    Quote Originally Posted by qr3379 View Post
    It was running fine, and then just went into limp mode with the maintenance light on. Got it back to the dock, and noticed that the rear cylinder wasn't firing since there was wet residue on the spark plug. I put new plugs it, it ran fine for about 40 minutes and then the same thing. Got it back to the dock and again the rear cylinder wasn't firing. I switched the plugs around and the rear cylinder still will not run. I checked to see if it had spark and it does, but it appears that it may be slightly un-normal. I'm not sure if the RFI have injectors that could be clogged or if it definitely is the coil pack. Any suggestions would be greatly appreciated.
    You should do a compression test first. Ideally you will have 150 psi in both cylinders. Post the test results and we will go from there.

  3. #3

    Join Date
    Aug 2012
    Location
    Pennsylvania
    Posts
    17
    Compression is ok in the cylinders

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 Sea-Doo GTI LE RFI propulsion problem
    By cpmanntx in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-23-2015, 09:23 AM
  2. 04 Seadoo Gti Le Rfi not charging problem
    By Spider228 in forum 2-Stroke Performance
    Replies: 12
    Last Post: 08-12-2013, 01:58 PM
  3. 2005 Seadoo GTI LE RFI
    By impulsive in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-15-2011, 06:04 PM
  4. GTI LE RFI pros and cons 2005
    By hdzcar in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-06-2011, 06:55 AM
  5. Narrowing it down on First Sea Doo purchase-2005 GTI LE RFI?
    By X-Cane in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 03-31-2008, 08:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •