Results 1 to 4 of 4
  1. #1

    how do I know if it is cooling right?

    I have a 1989 waverunner 500 that I bought from an auction for $60. After pulling a rock out of the pump and some minor electrical it runs. My question is how hot are these engines suppose to run? is it just the warm water not cooling it well or what because after running it the engine is too hot to touch for more than a few seconds. Since it doesn't have a pisser on the side for water to expel, then how do I know that it is actually cooling right? I'm not in the mood right now to buy a new top end kit for it right now since it seams to have a ton of power and revs wide and high.


  2. #2
    Mine runs perfectly good hours at a time, and it doesn't become very hot. I can touch the side of the cylinders for a few seconds without getting too hot. Have you tried to ride it? Does it go over idle just fine? Or does it shut down to limp mode 2500> rpm's?

  3. #3
    Quote Originally Posted by mtviking View Post
    Mine runs perfectly good hours at a time, and it doesn't become very hot. I can touch the side of the cylinders for a few seconds without getting too hot. Have you tried to ride it? Does it go over idle just fine? Or does it shut down to limp mode 2500> rpm's?
    Its never gone into limp mode on me. I hope the sensor for that works in the first place. I am trying to get it out to the river near by when I get the time, but for now ive been tuning it and riding it in a 2 acre pond, and I am wondering if the water is too warm in it, that or there is sand reststricting the water flow through the exhaust.

  4. #4
    CRJ's Avatar
    Join Date
    Aug 2013
    Location
    Halton Hills
    Posts
    269
    +1
    14
    basically, if after a ride water splashed on it boils, its too hot. on a garden hose mine is ice cold when running. in the water mine gets hot enough that i can only keep my hand on it for 4-5 seconds. never gets hotter.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How do I know if my bilge pump/system is working?
    By InsideTrader in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-01-2013, 10:37 AM
  2. How do I know if my VTS is 'Level'
    By crackofdawn in forum 2-Stroke Performance
    Replies: 6
    Last Post: 10-04-2011, 12:50 PM
  3. How do I know if the trim is working seem to rise high when i acc......
    By newwbiesl750 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 06-15-2011, 11:04 AM
  4. 95 Fuji 750 - How do I know if my cylinder is shot or not?
    By jasper in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-20-2009, 01:44 PM
  5. How do I know if the cooling system is working
    By utahnewbie in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-31-2007, 09:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •