Results 1 to 6 of 6
  1. #1

    Join Date
    Jul 2012
    Location
    fairhope alabama
    Posts
    149
    +1
    1

    97 polaris SLT won't rev up

    My polaris SLT 780 won't rev up when in water. I can start it up on land it it does fine but in water it doesn't go fast at all. It has a new battery, oil seals, and fuel pump. I have bypassed both the fuel and the oil sending units to make the MFD think it has a fuel tank. I have even used a lawn mower gas tank with the seat off and hooked it to the fuel pump and it still won't go fast. Does any one know what my problem might be?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,272
    Cylinder compression?

    Does the engine rev up normally when in the water?

  3. #3
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    I had the same problem with my pro. I had the coil wires connected.wrong. kinda hard to get the plug wires wrong because they usually just make it to each plug. Were you messing around in the ebox coil wires?

    Otherwise your wall clearance to prop is huge from sand melting the propbdown and

    now there's a huge gap between the 2.

    Or another scenario could be your ride plate is not sealed

  4. #4

    Join Date
    Jul 2012
    Location
    fairhope alabama
    Posts
    149
    +1
    1
    no that is where my problem is at i think out of the water it revs up high

  5. #5

    Join Date
    Jul 2012
    Location
    fairhope alabama
    Posts
    149
    +1
    1
    I was in the box because i had to take the motor out of the ski to replace the seals, but i know the plug wires are right but maybe in the box i didn't do something right

  6. #6

    Join Date
    Jul 2012
    Location
    fairhope alabama
    Posts
    149
    +1
    1
    does any one know how i can check the condition of your jet pump and the sealing of the ride plate?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 Polaris SLT 780 - Will not rev
    By 5Bulldogs in forum Polaris PWC Performance
    Replies: 10
    Last Post: 07-09-2016, 11:29 PM
  2. 97 WR 3 won't rev up.....trouble shooting
    By desertmariner in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 06-02-2013, 07:54 PM
  3. 97 XP won't rev up HELP!!!
    By jared427 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 09-01-2008, 07:19 PM
  4. 97 XP won't rev up HELP!!!
    By jared427 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-25-2008, 12:39 AM
  5. MSX 110 Won't rev up fully
    By bcbill in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-26-2007, 12:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •