Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1

    Big Problems w 11' RXTX... Anyone having ECM or Fuel Issues? Help!!!

    I checked the plugs, coils, battery, and pump (ring and prop), dealer confirmed all have checked out including the charger to make sure it didn't need a rebuild. They are leaning on a potential ECM or fuel issue which won't throw a code. Anyone else having these issues or have any advise????


  2. #2
    SELF27's Avatar
    Join Date
    May 2013
    Location
    Austin, TX
    Posts
    202
    +1
    16
    What are symptoms?

  3. #3
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Quote Originally Posted by SELF27 View Post
    What are symptoms?
    +1

  4. #4
    Quote Originally Posted by SELF27 View Post
    What are symptoms?
    To me it acts like the charger is slipping but I guess it could be the ECM or a fuel issue as well.... Its like sometimes there's power and sometimes not... I can rip it wide open and there be nothing or there be plenty of initial power. In either case, the best RPM is right around 6000 w a top speed of like 54 or so.

  5. #5

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    3,447
    +1
    653
    Sounds like loose hose somewhere. Check all your clamps/hoses. I went through this when I bought my 2010 TX back in the day

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Loose hose or charger slipping.
    Did you check the charger slip with a tool??

    How many hour on the unit?
    Might need a rebuild on the s/c.
    You can't trust the stealerships advice 8 out of 10 seadoo shops have very poor techs working.

  7. #7
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472

    Cool

    I've seen a stealership tell my client that his ski needed a new ecu and he was ready to drop 1k+

    He was bitching at me like I did it.
    I changed the spark plugs and ran 6-7 oz of Lucas fuel Injector cleaner in it and she fired right up at the lake.
    I then told him I had to test it and ran 8k+ rpm for over 30 min till he was waving me in.
    He thought I was gonna blow it up..
    I told him that I was only charging $500 for the fix..
    I didn't actually charge him but that just shows you how stupid people and stealerships can be.

  8. #8
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Start with the easy stuff 1st.
    New plugs and 6-7 oz of Lucas Injectors cleaner.
    It's $7-8 at Walmart for 32oz.
    A clogging/clogged Injector will make it run like crap.

    Then run her wot for 20-30 min with that Injector cleaner..

  9. #9
    how about you get the intercooler checked for leaks first.

  10. +1 by:


  11. #10
    pete71's Avatar
    Join Date
    Apr 2007
    Location
    AUSTRALIA(Melb)
    Posts
    685
    +1
    21
    Quote Originally Posted by winterstick View Post
    how about you get the intercooler checked for leaks first.
    Yep simular symptoms to what I had ..... Leaking intercooler

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 SLH Problems either stator or fuel issues not sure HELP
    By tbux2009 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 06-26-2011, 09:34 PM
  2. Anyone having wastegate or turbo issues?
    By EXTREME HONDA in forum Honda Open Discussion
    Replies: 1
    Last Post: 08-13-2010, 03:39 PM
  3. Anyone have pictures, or know someone with a flat or matte gpr??
    By GMNTMRE in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 10-08-2009, 10:06 PM
  4. 11.....Does anyone have any pics of his ski or link..
    By jonny5 in forum Open Discussion
    Replies: 5
    Last Post: 08-13-2007, 11:53 PM
  5. Anyone have a or B kit results.
    By rxpstan in forum 4-Tec Performance
    Replies: 16
    Last Post: 03-14-2006, 09:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •