Results 1 to 3 of 3
  1. #1

    loss electrical power

    My gp1300r just died. No dash display lights and wont crank over. I put the charger on. positive on battery and negative on the head and it charges. I looked at the fuses in the round container in the back and they aren't blown. I also took the switch in the front apart to make sure the green start button was depressing. Not really sure whats broken. Any ideas?


  2. #2
    dockwalker's Avatar
    Join Date
    Mar 2010
    Location
    On the water near Belhaven,NC
    Posts
    333
    +1
    19
    BATTERY! Been there.Try a new or a borrowed one.See if that turns it over.If not, other problems.

  3. #3
    Quote Originally Posted by dockwalker View Post
    BATTERY! Been there.Try a new or a borrowed one.See if that turns it over.If not, other problems.
    Ok i have another jet ski so i'll yank the battery from that np.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of Electrical Power with Gauges Frozen
    By Canaveral in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-16-2011, 01:26 PM
  2. Loss Of Power/RPM Drop
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-26-2007, 12:44 PM
  3. loss of power ( Max rpm 7000 ) after 7 hours
    By LAB69 in forum 4-Tec Performance
    Replies: 34
    Last Post: 04-02-2007, 04:59 PM
  4. 96 sl900 loss of power
    By scorp in forum Polaris Open Discussion
    Replies: 11
    Last Post: 01-08-2007, 07:18 PM
  5. Loss of power 04 RXP
    By PossisRXP in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 05-14-2006, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •