Results 1 to 8 of 8
  1. #1

    Join Date
    Jul 2011
    Location
    Copake Lake
    Posts
    20

    Need Help Deteriming A Problem (video)

    So I posted a couple days ago that I purchased a 2008 RXT in 2010 as a leftover. 27 hours on the PWC, Last time I rode it was on Fathers started started up great and ran smooth. Saturday I go and take it for a ride starts up Fine and runs fine then all of a sudden I feel that is it is not reving out to the highest RPMs I took a video of it starting up on the shore station lift. Just wanted to hear your thoughts? Could it be the Plugs? Could it be the Gas? I just ordered new plugs for it.


  2. #2
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    Plugs would be where I would start

  3. #3
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94
    could be anything WHO KNOWS???? lol plugs are always a good place to start. Check your coil packs and electrical connections in that general area. How old is the gas?

  4. #4

    Join Date
    Jul 2011
    Location
    Copake Lake
    Posts
    20
    there was about 3/8 of a tank left from last year then filled it up before the ski went in the water about memorial day

  5. #5
    leejax01's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville
    Posts
    1,161
    +1
    98
    Order plugs? You can pick up from the local Advanced Discount Auto or mostly ant auto parts store. Take yours in and make sure you get the ones that have the removable tips.

  6. #6
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    DO you smell raw gas in the exhaust? I say the coil packs worked their way UP...The large black plastic cover that says 4tec supercharged, you can pop it off with the 2 tabs in the corners...Look top see if the coils underneath are pushed down...

    If its plugs, NGK 4339...they have the removable tips.

  7. #7

    Join Date
    Jul 2011
    Location
    Copake Lake
    Posts
    20
    Quote Originally Posted by Danny View Post
    DO you smell raw gas in the exhaust? I say the coil packs worked their way UP...The large black plastic cover that says 4tec supercharged, you can pop it off with the 2 tabs in the corners...Look top see if the coils underneath are pushed down...

    If its plugs, NGK 4339...they have the removable tips.

    Do I remove the Tips on the spark plugs?

  8. #8
    Turbofab's Avatar
    Join Date
    Feb 2013
    Location
    Clearwater FL
    Posts
    330
    +1
    21
    ^^^ yes

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help analyzing a problem
    By vduzin12 in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-14-2012, 01:07 PM
  2. Need help! '08 RXPX problem
    By DCoog in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-28-2009, 09:13 PM
  3. I Need Help Diagnosing A Problem..
    By mikefeliz7 in forum 2-Stroke Performance
    Replies: 22
    Last Post: 02-17-2009, 06:29 PM
  4. Need help with Spark Problem on a 89 WR500
    By vinnie333 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 06-24-2008, 06:35 AM
  5. Need help with bucking problem
    By jgustman in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 01-09-2007, 05:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •