Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Aug 2012
    Location
    Fernley NV
    Posts
    5

    1999 polaris genesis DI wont turn off and gauge stays on all the time

    hello I bought a 99 di Polaris and it wont shut off I hit the stop button and nothing also pull the lanyard and nothing then I disconnected the battery and it still runs only way to kill it is take 2 plug wires off. I just replaced the lr module with a new one I check the lanyard micro switch please let me know if you can help. I checked the e box and it is grounded to the motor. checked all the switches start/stop and lanyard kill all work with a ohm meter. Ski only has 109 hours on it. when it is running if you hit the start/stop button it ingages the starter again.


  2. #2
    I'm addicted to Polaris PWC
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    919
    +1
    21
    Welcome to The Hulk!

    EDIT: Deleted as I posted info specific to carbed models!
    Last edited by ghostinstallations; 07-09-2013 at 08:50 AM.

  3. #3
    Click my Avatar for signature links, Polaris info
    Join Date
    Jul 2007
    Location
    Toronto, Canada
    Posts
    27,925
    +1
    448
    Sounds like the EMM or the kill switch wiring to the EMM may have problems.

    The lanyard kill switch works by grounding the Yellow/Black wire to the EMM. Find the Yellow/Black wire and trace it to the EMM. Make sure that when the lanyard is pulled it is actually grounding the kill wire at the EMM.

    The 1999 FFI Genesis (Ficht engine) was known to have wire harness issues. You may need to pull apart some wire harness splices and inspect for corrosion or bad connections.

  4. #4
    Click my Avatar for signature links, Polaris info
    Join Date
    Jul 2007
    Location
    Toronto, Canada
    Posts
    27,925
    +1
    448
    Quote Originally Posted by ghostinstallations View Post
    Welcome to The Hulk!

    Well, if the black/yellow wire at the CDI is grounded when you hit the start stop button, the CDI has failed. If it does not, its the LR module. Cant be the switch because it allows the ski to start, and it is unlikley that you have more than one issue, so I would rule out the saftey lanyard.

    Being a 99 genesis, there was a seperate LR502 start stop module. Did you replace that? Or the LR23 rectifier?
    OP says it is a DI engine, not CDI...

  5. #5
    I'm addicted to Polaris PWC
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    919
    +1
    21
    Quote Originally Posted by K447 View Post
    Quote Originally Posted by ghostinstallations View Post
    Welcome to The Hulk!

    Well, if the black/yellow wire at the CDI is grounded when you hit the start stop button, the CDI has failed. If it does not, its the LR module. Cant be the switch because it allows the ski to start, and it is unlikley that you have more than one issue, so I would rule out the saftey lanyard.

    Being a 99 genesis, there was a seperate LR502 start stop module. Did you replace that? Or the LR23 rectifier?
    OP says it is a DI engine, not CDI...
    Totally missed that...thanks!

  6. #6

    Join Date
    Aug 2012
    Location
    Fernley NV
    Posts
    5
    well I checked all the lanyard and kill swith they are good so if I use a ohm meter and I hold it at the emm on the yellow and black wire and touch the motor it should show that it completes a circuit right. that would show that it is grounding right. I checked the bl/yw wire right where in unplugged from the switch and I had continuity all the way back to the emm so I know that wire is connected from the front to the emm.

  7. #7

    Join Date
    Aug 2012
    Location
    Fernley NV
    Posts
    5
    Another thing is it will start without the lanyard connected. once I hook the battery up gages all work and never shut off and will crank so somewhere its not cutting the power off.

  8. #8
    Click my Avatar for signature links, Polaris info
    Join Date
    Jul 2007
    Location
    Toronto, Canada
    Posts
    27,925
    +1
    448
    Quote Originally Posted by geoffy18 View Post
    Another thing is it will start without the lanyard connected. once I hook the battery up gages all work and never shut off and will crank so somewhere its not cutting the power off.
    In normal conditions the display will always show the clock, it is never 'blank'.

    It internally changes to a low power sleep state after five minutes of no activity, but the clock continues to be visible.

    Starting without the lanyard tells me the EMM is not seeing the kill signal, or is ignoring it.

  9. #9

    Join Date
    Aug 2012
    Location
    Fernley NV
    Posts
    5
    ok I took the big 40 pin connector off the emm and I did a continuity on the bl/yw wire I touch the wire and then touch the block to see if I have continuity and I did then while I had full continuity I put the lanyard key in and if only showed 3/4 of the meter for continuity. So what does that tell me

  10. #10
    Click my Avatar for signature links, Polaris info
    Join Date
    Jul 2007
    Location
    Toronto, Canada
    Posts
    27,925
    +1
    448
    Quote Originally Posted by geoffy18 View Post
    ok I took the big 40 pin connector off the emm and I did a continuity on the bl/yw wire I touch the wire and then touch the block to see if I have continuity and I did then while I had full continuity I put the lanyard key in and if only showed 3/4 of the meter for continuity. So what does that tell me
    Work in ohms. Continuity readings don't tell me much, except for perfect connection and open circuit.

    What ohms does the circuit have with lanyard in, and with lanyard out?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Virage TXi and 1999 Polaris Genesis 1200 Help!
    By Big Willy in forum Polaris Open Discussion
    Replies: 20
    Last Post: 06-27-2011, 09:52 PM
  2. 1999 Polaris Genesis wont crank sometimes
    By nothinbutime in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-06-2009, 10:45 AM
  3. 98 polaris slxh 1050 wont turn off headsup display or power
    By mcguirejosh in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-30-2009, 06:07 PM
  4. 1999 Polaris Genesis Carb model need help with this one also
    By scottyboat in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-17-2007, 10:30 PM
  5. 1999 Polaris Genesis 1200 "Sleeper" project
    By SCXtrmSnwNWtr in forum Polaris Projects
    Replies: 23
    Last Post: 05-12-2007, 06:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •