Results 1 to 6 of 6
  1. #1
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140

    LR 23 Lost its magic smoke

    Any comments / opinions on why this might happen??

    Click image for larger version. 

Name:	IMG_1310.jpg 
Views:	54 
Size:	102.3 KB 
ID:	306071


  2. #2
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Never seen that before.
    Do you have a spare one?

    I might have one...plus I still have one of Bryan's.

  3. +1 by:


  4. #3
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    I have to check when I get home. I think I do.

    Bilge still runs and fuse is OK, so not sure what happened..... No other wires damaged except the off gassing discolored some of the wires. Ski still starts and runs fine.....

  5. #4
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    If you replace it, Id love to cut it open.

    I would check your charging voltage with a volt meter. These are shunt regulators, and if fried will no longer regulate voltage. You dont want to cook your battery.

  6. #5
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by ghostinstallations View Post
    If you replace it, Id love to cut it open.

    I would check your charging voltage with a volt meter. These are shunt regulators, and if fried will no longer regulate voltage. You dont want to cook your battery.
    When I said bilge still runs, I meant when directly connected to the battery. The bilge was dead when connected to the orange LR feed, so I will be replacing it. PM me your address and I'll send it along.....

  7. #6
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Looks like I am in need of one. If anyone has an LR23 available, please let me know.

    Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to check if bellows has lost its tension?
    By nd4spdbh in forum 4-Tec Performance
    Replies: 47
    Last Post: 05-05-2013, 10:50 PM
  2. Replies: 4
    Last Post: 07-10-2012, 12:55 PM
  3. Super Jet Lost its snap
    By spit in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 05-29-2011, 03:25 PM
  4. I lost it!!!!!! ugggghhh!!
    By RustySeaRustyDoo in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 08-02-2006, 10:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •