Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8

    Reoccurring knock sensor out of range

    So all year last year I had a reoccurring issue with my knock sensor and it throwing a code. So this year when I had to replace the head gasket I put in a new knock sensor but now its throwing the code again...any ideas?


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Pigtail update?

  3. +1 by:


  4. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Harness issue, wires too knock sensor going bad..?

  5. #4
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8
    Yepp, go the pig tail update. Any idea how I'd go about testing the wires to the knock sensor?

  6. #5
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    is the knock sensor tourqed correctly
    Should be 24Nm (18 lbf.ft)
    Last edited by westy; 07-10-2013 at 04:30 PM. Reason: Added Correct Tourqe

  7. #6
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    Quote Originally Posted by oct6454 View Post
    Yepp, go the pig tail update. Any idea how I'd go about testing the wires to the knock sensor?
    Use a Multimeter and check the wires from the Knock Sensor Plug back to ECM (For good continuity and making sure there is no shorts to earth etc) Using the appropriate wiring diagram You have a 04 I believe? as I just checked my 08 manual and the wiring diagram shows pins A-9 and A-23 are the pins for knock sensor in 08 they may be the same for a 04
    (P.S when testing your wires move them around to make sure there is no brakes damage in the wire ect)

  8. #7
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    What's the update on this?

  9. #8
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8
    havent gotten a chance to test it. I plan on trying to troubleshoot it tomorrow or possibly this evening. I'm so bad with those multimeters, but I'll try and see if i can figure it out.

  10. #9
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    I've got a good knock sensor off my motor.

  11. #10
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8
    Thanks, this is a brandnew one I ordered from the online store so I dont think its the sensor.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 RXT P0326 knock sensor out of range diagnosis
    By TJBrad04 in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-01-2016, 12:17 AM
  2. Replies: 10
    Last Post: 07-24-2016, 03:03 PM
  3. Pressure Sensor Out of Range
    By TheEngineer in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-12-2012, 11:18 AM
  4. P-0236 KNock Sensor out of Range
    By oct6454 in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-10-2011, 01:04 PM
  5. HELP: Trouble Code 0326 Knock Sensor out of Range
    By majundecid in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-23-2007, 08:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •