Results 1 to 4 of 4
  1. #1

    94 Polaris SLT 750 Running Sluggish

    I just recently put my watercraft in the water and it seemed like it was running slugging off the start, like the water was not sucking up properly. Had okay top speed but still was a bit under. Now it felt like it sucked some weeds up but I flipped the sea doo up and I don't see any and it's just running slow in the water. Hard to plane out and then slow once it planes out. Can anyone give ideas please of what is wrong.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,580
    +1
    1,272
    Welcome

    Either then engine is low on power, or the jet pump has a problem.

    See my signature links for info on how to inspect the jet pump. You may need to remove the jet pump and inspect the drive splines, the pump bearings, and the impeller blade clearances.

    Another area that can cause weak acceleration is if the sealant around the ride plate perimeter or the jet pump base has developed gaps and air leaks.

  3. #3
    Hey thanks for the info...I'm not able to clink on your links the server says it will not respond!!!

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,580
    +1
    1,272
    Quote Originally Posted by b blake View Post
    Hey thanks for the info...I'm not able to clink on your links the server says it will not respond!!!
    Try a different browser.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 Polaris SLT 750 Rebuild - Carb Tuning Help
    By BlueFishCrisis in forum Polaris Projects
    Replies: 2
    Last Post: 09-05-2011, 07:53 PM
  2. Polaris slt 750 runs but bogs when reving!
    By Mrjingles in forum Polaris Open Discussion
    Replies: 4
    Last Post: 10-13-2010, 08:47 PM
  3. Polaris slt 750 runs but bogs when reving!
    By Mrjingles in forum Open Discussion
    Replies: 1
    Last Post: 10-13-2010, 03:40 PM
  4. 94 polaris slt 750 hull + extras north florida..
    By nick34 in forum Polaris Classifieds
    Replies: 3
    Last Post: 08-28-2009, 05:19 AM
  5. 94 Polaris SLT 750
    By Yammerhead in forum Polaris Open Discussion
    Replies: 27
    Last Post: 09-19-2008, 02:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •