Results 1 to 8 of 8
  1. #1

    oil injection on dfi genesis

    I purchased an 01 with a burnt up piston #2, and I'm trying to determine what caused the failure. I'm in TX and don't have any local parts or repair resources. The oil injection pump doesn't seem to be putting anything out when I crank the engine at wot. Should I see oil in the throttle body? I removed the supply hose from the injection pump and I'm getting good gravity flow from the reservoir but after disconnecting the individual lines from the throttle bodies I'm not getting any kind of oil flow while cranking the engine with the throttle and oil lever at wot. Any help is greatly appreciated.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Oil flow is very gradual on these engines, especially at low crank RPM.

    Do you have reason to suspect an oiling failure? A lubrication failure has specific characteristics, particularly scratches and vertical scoring on both piston and cylinder wall.

    Post some photos of the piston and the cylinder walls.

  3. #3
    Will try to get pics, catastrophic piston damage. Burned hole in top of the piston, to me looks like it leaned out. Going to get fuel pressure readings tonite. With the head off, you could see the injector spray but that's without any resistance from the compression stroke.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by jaychadwick View Post
    Will try to get pics, catastrophic piston damage. Burned hole in top of the piston, to me looks like it leaned out. Going to get fuel pressure readings tonite.

    With the head off, you could see the injector spray but that's without any resistance from the compression stroke.
    Do not fire the injectors unless they are bolted into the cylinder head. The Ficht fuel injectors are very different from automotive injectors.

    See my signature links for more details on how the Ficht system works and the common issues.

  5. #5
    I left the injector in the head. I appreciate the info, I have read some of your other threads and you seem to have a lot of experience with these engines.

  6. #6
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    I have a simmilar issue with one of my Virages I will be rebuilding this weekend. Looks like the PTO leaned out, but my fuel pressure is good. My plan is to replace and program the PTO injector. If your fuel pressure is low, it just may be that that one leaned out first and a regulator/fuel pump repair is all you need.

  7. #7
    So I've been looking at some other threads and looking towards checking crank index. I've been thinking lately now that the piston fell victim to pre ignition from bad fuel and when the piston started to hit the head it retarded the timing increasing precombustion.

  8. #8
    Put the bike all together and ran, checked fuel pressure; zero. Pinched off return line and had 35 psi. Checked the pump module and the regulator had fallen into the module. I drilled a small hole in the supply/return piece and secured the regulator and supply line with safety wire. Put about 2 hours on the bike and seems to be running well. It's pretty neat that such a big bike still gets 50 mph! Thanks to all who replied!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil injection on a 97 xp???
    By tom3097 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 05-16-2011, 09:44 AM
  2. Leave / Remove Oil Injection on 2001 SUV?
    By jakew4 in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 10-24-2009, 08:22 PM
  3. 05 rxp How do you do the oil injection on supercharger.
    By JOSE13RT in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-13-2009, 10:56 PM
  4. Oil Pump Question on 99 Genesis
    By VegasRatt in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-03-2007, 10:29 AM
  5. Oil pump on genesis??
    By texoma in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 06-18-2007, 05:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •