Results 1 to 6 of 6

Thread: Polaris no go

  1. #1

    Join Date
    Jul 2013
    Location
    Logan, Ohio
    Posts
    30

    Polaris no go

    New 2 greenhulk-seems very informative. I have 1992 Polaris sl 650 that doesn't want to go. Starts great, idles great, but when u hit throttle might only get 5mph. Shoots water out decent. Put new reeds and plugs n it. 2 cylinders farthest from fuel pump have lots of carbon on them and plugs are dirtier than the first cylinder. Could this b fuel problem?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Welcome

    See my signature links for the common maintenance items on your blue Fuji engine.

    Is the engine revving up but the jet pump not delivering thrust? Or is the engine not producing proper power and RPM?

  3. #3
    How long has it sat up. Carb Rebuild might be due. If it shoots out water good I don't think you have pump problems.

  4. #4

    Join Date
    Jul 2013
    Location
    Logan, Ohio
    Posts
    30
    Does anyone know where to hook up a water hose connection to Polaris sl 650?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by checkmate305 View Post
    Does anyone know where to hook up a water hose connection to Polaris sl 650?
    Depends on the year, in part.

    Why do you need to hook up a garden hose? Engine can run 20-30 seconds from cold without water.

    Maximum run time even on the hose is two minutes, unless you remove the jet pump and drive shaft.

  6. #6

    Join Date
    Jul 2013
    Location
    Logan, Ohio
    Posts
    30
    Been discussing the ski having lack of power when at full throttle with a few people. Guy said it was propulsion problem and to hook water hose to, guess to make sure it was shooting out water. Though I might try it for process of elimination. From what I've been reading I think it needs carb rebuild and new fuel pump.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 4-Tech is drving me nutz.. Rev & no Go
    By cchris0411 in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-18-2008, 01:32 AM
  2. Any FL Polaris jockeys going to this?
    By BBCaprice in forum Polaris Open Discussion
    Replies: 2
    Last Post: 01-10-2008, 05:09 PM
  3. 01 Virage Tx NO GO :(
    By vinardas in forum Polaris Open Discussion
    Replies: 37
    Last Post: 06-11-2007, 06:49 PM
  4. Newbie with 96 Polaris sl780 going slow
    By lodough780 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 05-11-2007, 02:40 AM
  5. any polaris junkys going to mudbug?
    By addicted in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-09-2007, 01:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •