Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2008
    Location
    windsor ont
    Posts
    640
    +1
    8

    accellerator pump

    brand new carbs and i cant get the acc pump to work for the life of me.open to any suggestions


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    With the engine running, take a flat screwdriver between the cam ad the pump plunger and depress the plunger for a few seconds. It should prime the pump.

  3. #3
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,776
    +1
    400
    welcome to my world,at least 3 of the 5 new sets i bought the accl pumps wouldn't work.had to replace the plunger on 2 of them and that part is nla now.

  4. #4

    Join Date
    Jun 2008
    Location
    windsor ont
    Posts
    640
    +1
    8
    Quote Originally Posted by BryanP View Post
    With the engine running, take a flat screwdriver between the cam ad the pump plunger and depress the plunger for a few seconds. It should prime the pump.
    does not work.i think i tried everything posted.

  5. #5
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,776
    +1
    400
    do any of the squirters shoot fuel at any time??if no skip ahead.if yes,does one of them not??one of the new sets had the pto squirter ball stuck closed in the nozzle.i used air to unstick it but the ball must have been pitted.replaced the nozzle and it was better.all of my keihin carb sets have had the plastic check ball removed from the metering block and replaced with steel.yet they still had issues with not fully displacing the trapped air.put in a new diapraghm on one and that fixed it,put a used one in another set and that fixed it.only other thing i can think of is to pull the pto feed hose off the squirter and try the screwdriver trick again.cover the hose end when you release the screwdriver.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Bilge Pump install
    By Vern in forum 4-Tec Performance
    Replies: 14
    Last Post: 08-27-2014, 10:04 AM
  2. Skat-trak pump mod
    By nitro rxp in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-04-2005, 09:00 PM
  3. PUMP MOD
    By peteshauling in forum 4-Tec Performance
    Replies: 20
    Last Post: 06-01-2005, 10:08 AM
  4. New Magnum pumps from Skat Trak
    By Green Hulk in forum 4-Tec Performance
    Replies: 34
    Last Post: 05-12-2005, 08:56 PM
  5. PUMP WEDGE
    By RXPNJ in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-10-2005, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •