Results 1 to 10 of 10
  1. #1

    2002 Polaris Virage TX Driveshaft

    Can you guys help me? What are the rubber pieces on the driveshaft for? Here are some pics, I didn't notice the other end of the shaft until I saw this picture. Would you replace the shaft? Would this be the cause of my vibration issue? A rock get sucked up my grate and jammed and stop the motor impeller have some nicks. See pics. Thanks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1792.jpg 
Views:	62 
Size:	45.3 KB 
ID:	306263   Click image for larger version. 

Name:	IMG_1793.jpg 
Views:	61 
Size:	46.8 KB 
ID:	306262   Click image for larger version. 

Name:	IMG_1795.jpg 
Views:	55 
Size:	64.4 KB 
ID:	306264   Click image for larger version. 

Name:	IMG_1796.jpg 
Views:	53 
Size:	34.8 KB 
ID:	306265   Click image for larger version. 

Name:	IMG_1797.jpg 
Views:	107 
Size:	56.5 KB 
ID:	306266  


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    That drive shaft looks too far gone for my taste. Splines seem badly worn and non-square. Are the mating splines also worn?

    The rubber end bumpers provide the only resilient provision in the entire driveline. They control the end to end play of the drive shaft. One end presses against the engine crank end, the other end presses on the impeller stub shaft. Replace that damaged end bumper.

    Check the impeller and the stator stub shaft for bent. If the stub shaft is bent it must be replaced. Impellers can be repaired and refurbished, if necessary.

    Unless it has been done recently, now would be a good time to replace the bearings and seals in the jet pump. And in the through-hull bearing assembly.

  3. #3
    Thanks K447, not sure about the mating splines but I will have a look.
    I will look into having the bearings and seals in the jet pump replaced and in the through-hull bearing assembly.
    Is this difficult to do?

    I might also require a new wear ring, it has some grooves in it!

    I had the unit out on the weekend and she doesn't sound right.
    Can you recommend anyone in the GTA (prefer West end) for repair.

    Thanks

  4. #4
    Look what I found when I took the pump apart!! I don't think that the impeller should almost fall off the stub shaft!! Wear ring needs to be replaced.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCN0411.jpg 
Views:	58 
Size:	80.2 KB 
ID:	310155   Click image for larger version. 

Name:	DSCN0412.jpg 
Views:	52 
Size:	84.2 KB 
ID:	310156   Click image for larger version. 

Name:	DSCN0416.jpg 
Views:	43 
Size:	34.4 KB 
ID:	310157  

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by Izzy View Post
    Look what I found when I took the pump apart!! I don't think that the impeller should almost fall off the stub shaft!!

    Wear ring needs to be replaced.
    And the pump bearings, and the seals. New stub shaft. The impeller needs to be replaced, I expect (spline damage). And the drive shaft.

    Is the stator damaged?

  6. #6
    Any leads on parts within GTA?
    It appears that the impeller unscrewed itself.
    Stub shaft appears ok.

    Impeller definitely needs replacing, sides worn from rubbing on wear ring? Quite the gap!!

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by Izzy View Post
    Any leads on parts within GTA?
    It appears that the impeller unscrewed itself.
    Stub shaft appears ok.

    Impeller definitely needs replacing, sides worn from rubbing on wear ring? Quite the gap!!
    You sure about that stub shaft? Looks like the threads are missing from the end portion.

    Click image for larger version. 

Name:	3240139.jpg 
Views:	53 
Size:	341.1 KB 
ID:	310162

    I don't know who has all those parts in stock in the Toronto area. I would expect that someone does.

    Or just order then from a US supplier, and pick them up from a stateside shipping address.

  8. #8
    Thanks for he info!
    I thought that was how the threads are there on the stub shaft!
    Add something else to the bill!!

  9. #9
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,135
    +1
    1,050
    Member 785 Lugs has hardened ones for sale. Not that you need a hardened one, but he will prolly match the price on a standard used one.....just about anyway!!!

  10. #10
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,777
    +1
    401
    got a low hour pump setup for sale,17/22 long blade prop ready to go

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 polaris virage tx
    By KRR in forum Polaris Open Discussion
    Replies: 12
    Last Post: 08-25-2014, 12:01 AM
  2. Replies: 2
    Last Post: 07-18-2013, 01:19 PM
  3. water in electrical box on 2002 Polaris Virage TX
    By schnookie in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 05-31-2013, 06:28 PM
  4. 2002 Polaris Virage TX 1200 carb - no stop, now no start
    By Flatbottom383 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-05-2012, 09:15 AM
  5. 2002 Polaris Virage TX - MFI & SPEEDO stopped working
    By seabiscuit in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-13-2010, 05:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •