Results 1 to 2 of 2
  1. #1
    Chester's Avatar
    Join Date
    Apr 2007
    Location
    Coquitlam, BC Canada
    Posts
    174
    +1
    9

    2002 Genesis i Fuel Pump Not Running

    I'm working on a customers 2002 Genesis i and the fuel pump will not run. The breaker tests out OK, the CPS has 144 ohms, and the pump will run and build pressure when I ground the brown wire. Does this mean the EMM is shot? Is there anything else I should check?

    Chester


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Is the injector voltage rising to over 20 volts when cranking?

    Does the MFI display 'wake up' from sleep when you start cranking?

    Bypass the LR-503 Start/Stop module.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 Genesis FICHT fuel pump test run
    By elprup in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-02-2015, 08:02 PM
  2. 2002 Genesis carburetor engine, does not run properly
    By Rob Robinson in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-17-2014, 10:51 PM
  3. FS 2002 Genesis i fuel tank & Ficht fuel pump/sender
    By vxrpete8 in forum Polaris Classifieds
    Replies: 10
    Last Post: 05-30-2011, 03:25 PM
  4. 2002 polaris virage txi will not run, just back fires
    By motormadness in forum Polaris Open Discussion
    Replies: 15
    Last Post: 08-16-2010, 07:32 PM
  5. WTB: 1998-2002 DI, RFI fuel pump
    By boostaholic in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 08-25-2008, 07:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •