Results 1 to 9 of 9
  1. #1

    2000 gtx has no power

    I have a millennium edition gtx. It ran fine the last time it was out. It sat up for a while and the battery went dead. A new battery was installed. After the installation I get no response when the safety lanyard is attached. No beeps, no dash info, nothing. It was taken to a shop where it fired off a few times but "intermittent". They said that the mpem is bad. What would have caused this to happen? Is there anything I can check to verify their diagnosis? All the fuses in the mpem look good as well as the one in the rear electrical box. Could a malfunctioning wire harness be to blame? If so, which one. If the mpem is in fact bad, would it turn over at all? I appreciate any and all advise.

  2. #2
    Let me add that the buzzer has not chirped in a while, but the dash power has always maintained. Do I need the buzzer to help identify the issue? I read on a post that you can get them cheap from radio shack. Does anyone know what to ask for. I searched the radio shack web site and they have a ton of buzzers. As far as the dash power and absolutely no response from the lanyard I am still stumped.

  3. #3
    mudslanger's Avatar
    Join Date
    Jul 2010
    Huntsville Al
    was the shop that worked on it a shop that works on seadoo. did anyone try jumping it off if so then the mpem is probably fried. i have jumped the solenoid and things started working. i have 4 of the millennium edition ski in my shop at the moment and 2 have bad mpem and 2 with bad motors and 1 guy own all 4. he wants to make 2 run to sell. i am having similar issues on one with the good motor. my problem is it doesn't beep when key is inserted and display is dim but it spins over but wont fire. i have changed mpem and complete hood and complete coil box assembly and checked all wire plug connections including stator connection. the next thing before pulling motor is changing wire harness.

  4. #4
    The shop was not a seadoo dealer, it was a yamaha dealer. They said they had a seadoo expert on staff that would look at it. The ski has been jumped off before, but that was many years ago, probably in 01. We normally place the battery on slow charge a day prior to use. Does the mpem work intermittently, or when it goes it's gone? I have to work the next few days and then I will have 7 days off to dig into this thing and find plenty of more questions to bother you experts with. Mudslanger you said you will change the wire harness next. Is there a particular one that you will target?

  5. #5
    AndinoWatercraft's Avatar
    Join Date
    Feb 2008
    Puerto Rico
    When the lanyard is put does the info comes up? If yes get a multimeter and test the starter relay conection. This can be done putting the positive led on the red cable that goes from the relay to the starter. the black led to engine or battery ground. Push the start button and look for battery voltage on the metter. On the stator cover there is a little black ground cable. I belive this is the MPEM ground so if it gets rusted or looses contact wont power up the module. Remove all the MPEM connectors and inspect them for a loose or pushed back pin. Other test is to get a good MPEM and key to swap.

    just my .02.

  6. #6
    Here is an update to what my ski is doing. If I disconnect the battery and reconnect it WITH the lanyard on, I will get power to the dash and the ski will turn over. It will continue to turn over and maintain dash power until i disconnect the lanyard. If I disconnect the lanyard and reinstall it, I do not get power or turnover. I have to disconnect from the battery to regain power. Whatcha think?

  7. #7
    Thanks for the input AndinoWatercraft. I can only get the info to come up if I disconnect the battery and reconnect it with the lanyard on. I have checked the black mpem ground. It has a tight connection and appears to be clean. I did not pull it all the way off. I will go do that now.

  8. #8
    I put the battery on slow charge overnight. I went out and connected it this morning WITH the lanyard installed. She fired right up. I took her to the lake and she ran perfectly. The only issue is if I pull the lanyard I will have to reset the battery to get her to restart. I think I might just purchase a $40 disconnect switch instead of the expensive mpem.

  9. #9
    I had a bad MPEM recently and remember coming across this same issue in another post while I was searching for my symptoms. The op did the same thing, just installed a disconnect switch. It was a bad MPEM. It's possible the shop you took it to may have tried to jump it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 GP1200R WOT has no power. Feels like choke is on.
    By UFPD1881 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 06-08-2012, 07:01 PM
  2. 2000 GTX oiling up
    By Kraf-T in forum 2-Stroke Performance
    Replies: 5
    Last Post: 12-10-2007, 11:19 AM
  3. 2000 GTX 951cc
    By freeze in forum 2-Stroke Performance
    Replies: 4
    Last Post: 08-16-2007, 05:59 AM
  4. ? on 2000 GTX DI
    By hydrobuggp in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 08-15-2007, 12:12 PM
  5. 2003 GTX SC lost power
    By SBINBRANSON in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-06-2007, 07:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts