Results 1 to 2 of 2
  1. #1

    Question Is my RXP's speed sensor good?

    My speedometer suddenly stopped working. This was after having issues where the MPEM "forgot" this is an RXP and I had to have the VTS activated and compass/sounder de-activated. I followed the trouble shooting steps from the service manual. It says voltage should oscillate when turning the paddle wheel, between 5.5 and 8.5 volts. Mine oscillates from 5.4 to 9 volts. Is this within tolerance or can the sensor be the problem? I did see the speed sensor activated in the BUDS system.

    Any ideas??
    Thanks!

    J


  2. #2
    BUMP!

    I read on this forum that some guys had VTS problems and even though VTS was activated on BUDS, they should de-activate it, write to MPEM and the re-activate and write again, to make sure the ski recognized it. Any idea if this might also be needed to get the speedometer to work? It seems my oscillating voltage is alright so I'm trying to think what else it might be.

    Thoughts?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My RXP is faster than a triple piped STXr
    By LiquidDI in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 05-07-2013, 12:47 AM
  2. My RXP SC washer pic, good or bad?
    By robby212 in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-21-2010, 07:16 PM
  3. is my speed good for my mods...fx sho
    By wave15stx in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-08-2009, 04:01 PM
  4. How much is my RXP worth.
    By Therock in forum 4-Tec Performance
    Replies: 7
    Last Post: 01-26-2008, 01:00 AM
  5. My RXP Mod & Speed History
    By Jarrett in forum 4-Tec Performance
    Replies: 15
    Last Post: 06-02-2006, 12:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •