Results 1 to 2 of 2
  1. #1

    Question Is my RXP's speed sensor good?

    My speedometer suddenly stopped working. This was after having issues where the MPEM "forgot" this is an RXP and I had to have the VTS activated and compass/sounder de-activated. I followed the trouble shooting steps from the service manual. It says voltage should oscillate when turning the paddle wheel, between 5.5 and 8.5 volts. Mine oscillates from 5.4 to 9 volts. Is this within tolerance or can the sensor be the problem? I did see the speed sensor activated in the BUDS system.

    Any ideas??


  2. #2

    I read on this forum that some guys had VTS problems and even though VTS was activated on BUDS, they should de-activate it, write to MPEM and the re-activate and write again, to make sure the ski recognized it. Any idea if this might also be needed to get the speedometer to work? It seems my oscillating voltage is alright so I'm trying to think what else it might be.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Info on 2004 RXP Speed Sensor
    By seadawg in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-13-2014, 09:04 AM
  2. FS Speed sensor off RXP $45
    By RXP-TOM in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 07-31-2012, 11:30 PM
  3. WTB Looking for a speed sensor for Rxp
    By joewharton2 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 07-06-2011, 01:18 PM
  4. WTB: 2007 RXP speed sensor
    By watermedic in forum Sea Doo 4Tec Skis
    Replies: 2
    Last Post: 07-07-2009, 07:39 AM
  5. WTB: speed sensor of an 06-07-08 Rxp/Rxt.
    By TURBO TECH P.R. in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 03-06-2009, 12:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts