Results 1 to 6 of 6
  1. #1

    New 2009 15x wps, not working

    The gps throws a warning every time the key is put on and doesn't work. Anyone have some know how on the system. The owners manual doesn't help.


  2. #2
    Ok, did the check as per service manual and it points to the module being bad. Is there a way to disable it? I can silence the beeper, but the warning light continues to flash. Tried unplugging it to see if the light still flashed and it does.

  3. #3
    Fixed, new instrument panel.

  4. #4
    It is always the gauge cluster never the GPS module.

  5. #5

    Join Date
    Aug 2013
    Location
    Denver, NC
    Posts
    31
    +1
    1
    Is the GPS in the ECU or the cluster? Does anyone know if you replace with a GPS cluster than you would then have GPS?

  6. #6
    Quote Originally Posted by ccrunk1 View Post
    Is the GPS in the ECU or the cluster? Does anyone know if you replace with a GPS cluster than you would then have GPS?
    No the the GPS is a separate module. Don't worry, the your not missing anything, the GPS is pretty much useless.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 10-03-2011, 11:50 PM
  2. Msx 150, new wastegate and still not working
    By lopezmabin in forum MSX/Matrix
    Replies: 4
    Last Post: 05-29-2011, 11:55 AM
  3. 2001 Kawasaki 900 STS - MFD Not Working w/ New Display
    By travishansen in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 05-07-2011, 10:42 PM
  4. new mfd not working
    By pokechop2006 in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 07-26-2010, 07:04 PM
  5. new RXP-X speedometer not working on my machine
    By davidescu_radu in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-06-2008, 04:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •