Results 1 to 5 of 5
  1. #1

    Join Date
    Jul 2013
    Location
    Kansas City
    Posts
    3

    Question Help - new owner, used Seadoo. Won't start...

    We bought our first used Seadoo and had it out for an hour 3 days ago and for 5 hours today on and off all day - no issues. Brought it in, shut it off to pack up tonight and went to turn it back on to head to the dock and nothing. No sputtering, nothing. The key is fine, accessories turned on but nothing else. Battery is new. Engine is 2 years old. Where to start?? Or is this as easy as yep "it's the starter for sure"? Thanks for any help!

    1999 GTX Seadoo Fuel-Injected


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    What model is it??

    Does it do anything???

    Does it click???

  3. #3

    Join Date
    Jul 2013
    Location
    Kansas City
    Posts
    3
    GTX RFI - doesn't chirp anymore now either but electronics on dash work once the key is attached. You can hear noise in the back like it's getting ready to want to fire up but then when you press the start button, absolutely nothing. Worked great all day for nearly 5 hours with limited on/off's.

  4. #4

    Join Date
    Jul 2013
    Location
    Kansas City
    Posts
    3
    My husband just took the cover off the electrical box and there is a small layer of water in it?? I assume that should be sealed and could be the cause of a short? He can check the fuses but after that, if they are good - suggestions?

  5. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Check your electric connections on the battery.
    If its a new battery they could have vibrated loose.
    When tightening battery leads its good to use a socket because the screw driver sometimes does keep a good connection.
    Also check any other electric connections you can see.
    Then check fuses.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New 4tec motor install, won't start need help, timing?
    By richte18 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-10-2014, 09:50 AM
  2. Replies: 9
    Last Post: 07-12-2013, 09:14 PM
  3. Please help 99' polaris 700 slh won't start!!!
    By bullxi21 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-22-2011, 01:35 PM
  4. Seadoo won't start
    By Penney10 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 09-08-2010, 11:18 AM
  5. Need help with a 04 seadoo 3d not starting
    By 5Bulldogs in forum 2-Stroke Performance
    Replies: 24
    Last Post: 05-20-2010, 04:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •