Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1

    Blown R&D Ultimate Sea-Doo Pump Seal

    Like I said I blew the R&D Ultimate Sea Doo Pump Seal after only 3 hours of ride not hard riding either... I got a 06' RXP with ET 127, #42 Injectors, BOV, Thru Hull Exhaust, Shortened Water Box 4" Intake, R&D Intake Grate, New Wear Ring, New 15/20R Impeller. I was just wondering if anyone else have had a issue with the seal. Everything was great for the first part of the 3 hours I had zero cavitation (which is the reason I bought the seal cause I was cavitating like crazy) and with the new seal it pulled hard at WOT out the hole (no cavitation). I only got to ride it hard for maybe 10 minutes because my fiancée was with me about the whole time on the water. When it blew we was just cruising and I stopped, kept the engine running, and swapped spots to let my fiancée drive and she went to take off which she is very easy on it cause she hasn't really drove one before and the thing started cavitating like crazy so I got back up front to drive it and had to rev it up to get it to finally go. I loaded up right then came home and pulled the pump off and found the left side about 1 1/2" to 2" of the seal blown seal (wavy.) I checked the torque of the bolts before I pulled it off and it was still good. It sealed up real good when I installed it and the matting surfaces are smooth and no crack so I don't know what is going on... maybe I got a bad seal? Any help will be great? Thanks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20130713_184621_826.jpg 
Views:	310 
Size:	57.0 KB 
ID:	306623   Click image for larger version. 

Name:	IMG_20130713_184638_444.jpg 
Views:	344 
Size:	65.2 KB 
ID:	306624  


  2. #2
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Damn, I hope this is just a fluke!

  3. +1 by:


  4. #3
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    Mine has maybe 8 very hard hours with many wot hole shots seems to be holding up glad I saved my stock seal


  5. #4
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by mikelytle1077 View Post
    Mine has maybe 8 very hard hours with many wot hole shots seems to be holding up glad I saved my stock seal
    Did it help?

  6. #5
    da1nonlyrxp da1nonlyrxp's Avatar
    Join Date
    Oct 2007
    Location
    Oviedo, FL
    Posts
    185
    +1
    1
    Quote Originally Posted by Firemann2112 View Post
    Like I said I blew the R&D Ultimate Sea Doo Pump Seal after only 3 hours of ride not hard riding either... I got a 06' RXP with ET 127, #42 Injectors, BOV, Thru Hull Exhaust, Shortened Water Box 4" Intake, R&D Intake Grate, New Wear Ring, New 15/20R Impeller. I was just wondering if anyone else have had a issue with the seal. Everything was great for the first part of the 3 hours I had zero cavitation (which is the reason I bought the seal cause I was cavitating like crazy) and with the new seal it pulled hard at WOT out the hole (no cavitation). I only got to ride it hard for maybe 10 minutes because my fiancée was with me about the whole time on the water. When it blew we was just cruising and I stopped, kept the engine running, and swapped spots to let my fiancée drive and she went to take off which she is very easy on it cause she hasn't really drove one before and the thing started cavitating like crazy so I got back up front to drive it and had to rev it up to get it to finally go. I loaded up right then came home and pulled the pump off and found the left side about 1 1/2" to 2" of the seal blown seal (wavy.) I checked the torque of the bolts before I pulled it off and it was still good. It sealed up real good when I installed it and the matting surfaces are smooth and no crack so I don't know what is going on... maybe I got a bad seal? Any help will be great? Thanks
    I bought one and am putting everything back together, what's the torque for the bolts? hope i don't have the same issue.

  7. #6
    iron head's Avatar
    Join Date
    Aug 2006
    Location
    ONT CANADA
    Posts
    616
    +1
    2
    Quote Originally Posted by da1nonlyrxp View Post
    Quote Originally Posted by Firemann2112 View Post
    Like I said I blew the R&D Ultimate Sea Doo Pump Seal after only 3 hours of ride not hard riding either... I got a 06' RXP with ET 127, #42 Injectors, BOV, Thru Hull Exhaust, Shortened Water Box 4" Intake, R&D Intake Grate, New Wear Ring, New 15/20R Impeller. I was just wondering if anyone else have had a issue with the seal. Everything was great for the first part of the 3 hours I had zero cavitation (which is the reason I bought the seal cause I was cavitating like crazy) and with the new seal it pulled hard at WOT out the hole (no cavitation). I only got to ride it hard for maybe 10 minutes because my fiancée was with me about the whole time on the water. When it blew we was just cruising and I stopped, kept the engine running, and swapped spots to let my fiancée drive and she went to take off which she is very easy on it cause she hasn't really drove one before and the thing started cavitating like crazy so I got back up front to drive it and had to rev it up to get it to finally go. I loaded up right then came home and pulled the pump off and found the left side about 1 1/2" to 2" of the seal blown seal (wavy.) I checked the torque of the bolts before I pulled it off and it was still good. It sealed up real good when I installed it and the matting surfaces are smooth and no crack so I don't know what is going on... maybe I got a bad seal? Any help will be great? Thanks
    I bought one and am putting everything back together, what's the torque for the bolts? hope i don't have the same issue.
    26lbs

  8. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    I am not so sure that was causing your problem. I had oem seal installed backwards one time and it did not cavitate bad. If I had to guess, you had something in your pump causing the cavitation.

  9. +1 by:


  10. #8
    Steve STSPERFORMANCE's Avatar
    Join Date
    Dec 2007
    Location
    Cambridge, Ohio
    Posts
    2,701
    +1
    116
    If they are that tight going in it seems really easy too me to get it pinched. I would spray it with xps or something before install

  11. #9
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Did you have any water in your hull?

    I always lube up the pumpshoe before installing pump. I think its a good idea.

  12. #10
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    IMO that was not your issue, my stock seal looked WAY worse than that and did not cause any noticeable issues. more than likely you had something in your pump and it fell out. Put it back together and if there is nothing in your pump and or you're wear ring is not damaged from whatever happened it will be fine Im betting.


Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB Aluminum sea Doo pump out if non supercharged ski
    By IBADTON in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 03-09-2016, 10:56 PM
  2. #SparkSomeFun To Enter the Ultimate Sea-Doo Beach Party
    By Rustymuscle in forum The Watercraft Journal
    Replies: 0
    Last Post: 03-26-2015, 12:40 PM
  3. WTB Sea Doo Pump adaptor kit
    By Lvnspeed in forum Conversion Skis Classifieds
    Replies: 3
    Last Post: 09-04-2011, 08:46 PM
  4. Ultimate sea-doo fan contest for 2012
    By The Dolphin in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-17-2011, 03:42 PM
  5. RIVA Sea Doo Pump Wedge for RXP RXT GTX [email protected]@K!!!
    By fasted1500 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 09-18-2008, 09:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •