Results 1 to 10 of 10
  1. #1

    Oil consumption and smoke from exhaust

    I have a 2011 rxp that I just bought. It ran great for the first few hours. Then was bogging at low speeds. After checking it over found the inter cooler leaking water into the motor. I replaced that and everything was all good for about 15 hours of riding. It now smokes really bad and guzzles oil. I only have 80 hrs on the machine. It started to consume oil after riding for awhile. I would guess maybe a qt every couple hours. It has some upgraded parts. Blow off valve, through hull exhaust, not sure what else. It will smoke really bad at start up and then clear up at higher rpm but once I'm back to idle or just off I look like I'm fogging for Mosquitos. Any thoughts ??? I'm just looking to see if there is any common failures


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    What kind of oil are you running??
    What weight oil ???
    Was it doing this when you bought it or did it just start??

  3. #3

    Join Date
    Sep 2010
    Location
    South Florida
    Posts
    1,599
    +1
    123
    Quote Originally Posted by Rocket150 View Post
    I have a 2011 rxp that I just bought. It ran great for the first few hours. Then was bogging at low speeds. After checking it over found the inter cooler leaking water into the motor. I replaced that and everything was all good for about 15 hours of riding. It now smokes really bad and guzzles oil. I only have 80 hrs on the machine. It started to consume oil after riding for awhile. I would guess maybe a qt every couple hours. It has some upgraded parts. Blow off valve, through hull exhaust, not sure what else. It will smoke really bad at start up and then clear up at higher rpm but once I'm back to idle or just off I look like I'm fogging for Mosquitos. Any thoughts ??? I'm just looking to see if there is any common failures
    Welcome to GH. "A quart every couple of hours". I would start with a leak down and/or compression test. No oil in the hull as in a massive leak?

  4. #4
    Seadoo xps oil. I added a qt of castrol while on vacation because the alam went off. We rode it for a few more hours and the alam went off again so I added another qt. no smoke at this point and it runs great. A few days go by with some good riding. It starts to smoke a little at start up nothing major. I assumed it was a little over full with oil. As a day goes by the smoke is thick and white and is for sure oil. Brought it home and changed the oil with the seadoo oil hoping it would get better. It has not

  5. #5
    No major leaks. The hull is dry inside

  6. #6
    Can oil get forced into the motor from the super charger?

  7. #7
    Banned User
    Join Date
    Aug 2011
    Posts
    5,049
    +1
    238
    You shouldn't be going through oil like that! Any oil in the hull?

  8. #8
    Just finished a compression test. 130on all cylinders. The plug closest to the rear of the machine looked oily the other 2 looked good.I pulled the bloew off valve and looked in the charge pie and it looked dry no oil.

  9. #9
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Compression test will do no good if your cossuming oil your coating rings and receiving a false positive. Lets determine we're your oil may be comming from. Pull all plugs lets see is all plugs burning oil are you consuming oil or a oil leak externally? We will do the three likely Sc oil is getting suck in through your supercharger and getting into intake. Pull off hoses to and from sc and inspect. Check your tops valve and breather make sure you have proper ventilation. After that we can goto leak down test etc

  10. #10
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Ok so after posting and seeing your reply you can rule out supercharger,breather,exterior. Your problem is either a bad valve seal,piston rings,lands or bore. If you have a bore scope you can explore. Leak down test that cylinder

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 rxp 215 oil issue and smoking . please help !
    By rrryyyaaannn87 in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-07-2014, 08:36 PM
  2. Smoke from exhaust after rebuild
    By soccerinco in forum 4-Tec Performance
    Replies: 20
    Last Post: 01-06-2013, 12:01 AM
  3. ultra 300x.a mod to add hp and cut down on oil consumption and improve ring seal.
    By 300XXX in forum Kawasaki PWC Performance (4-stroke)
    Replies: 16
    Last Post: 08-16-2011, 04:34 PM
  4. 05 RXP oil smoke from exhaust?
    By HardmanGT in forum 4-Tec Performance
    Replies: 19
    Last Post: 06-06-2011, 10:23 PM
  5. 250x Smell of Gas in oil.. and heavy white exhaust now present
    By mugmainer in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 08-08-2007, 05:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •