Results 1 to 10 of 10
  1. #1

    New gauge cluster

    Hey guys,
    I recently had my gauge cluster replaced on my 07 rxp. At first the dealer said that they wouldnt install it for me since I didnt buy it from them, I bought it from the link on this forum, but after some convincing they said they would do it but they could not guarantee that it would work. Had someone pick up the ski for me and when it got home I noticed that the gas gauge doesnt work. Also the rpm gauge either shows 0 or 5000. The dial seems to work fine, the one above number display, but the digital readout will not. Does anyone know if this can be fixed or are the new gauge clusters not compatible with all skis? Maybe the dealer loaded the wrong software? Any help is much appreciated. Thanks!


  2. #2
    Quote Originally Posted by tomla05 View Post
    Hey guys,
    I recently had my gauge cluster replaced on my 07 rxp. At first the dealer said that they wouldnt install it for me since I didnt buy it from them, I bought it from the link on this forum, but after some convincing they said they would do it but they could not guarantee that it would work. Had someone pick up the ski for me and when it got home I noticed that the gas gauge doesnt work. Also the rpm gauge either shows 0 or 5000. The dial seems to work fine, the one above number display, but the digital readout will not. Does anyone know if this can be fixed or are the new gauge clusters not compatible with all skis? Maybe the dealer loaded the wrong software? Any help is much appreciated. Thanks!
    yes they loaded wrong software they know better than to pull one like this, i replaced my 06 cluster with a 0 hours brand new and it did the same thing 0 rpm then no reading but 5000 rpm, also the compass was crazy numbers and letters t567, y789 etc, if they are a real seadoo dealer they can flash it with the correct firmware i guess they don't like the idea you did not pay the exaggerated price they quoted you.

  3. #3
    might have selected boat when they married it

  4. #4
    Thanks for the quick replies! Definitely sounds like they loaded the wrong software because my compass was showing T 367 or something in that area. Ill call tomorrow and see what they say about fixing it. I just wanted to check and make sure that it was possible for all components to work properly before I called. They are a real seadoo dealer so they should be able to fix it. Thanks again for the info!

  5. #5
    If you have T codes they did not load the flash to the cluster at all... They just married it...

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    If the don't fix it right and for free then ask for the regional seadoo reps #
    Or pm tiny he's a dealership and he can direct you.

    Wow what bs that they couldn't get it right the 1st time.
    Sounds like they don't know how to doo it at all.

  7. #7
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    The previous version of BUDS would automattically update and marry the cluster. If they are running the newest version of BUDS they have to do it manually...

  8. #8
    So I just got off the phone with the dealer.. They claim that the gauge was working properly when the ski was picked up. I totally do NOT believe that but I guess its possible. They claim that it was loaded with the software or that it wouldnt come on at all. Then they tell me that they cant get to it until July 31! Looks like Ill be riding without a gas gauge until then... Thanks again for all the input!

  9. #9

    Join Date
    Oct 2010
    Location
    miami
    Posts
    38
    Hello, guys need help I have a 2008 seadoo rxt-x I've had the ski for five years, the cluster was broken with water inside for two years I finally saved up and just bought a brand new cluster from seadoo online took it to my nearest dealer and had them program it, now cluster shows 0 hours, compass shows t 255 Rpms shows 0 or 5000 outside temp not working speedometer shows 0, I took it back to them and argued they did not program it properly they state there's nothing else they can do ? How did you guys fix this issue thanks

  10. #10
    Quote Originally Posted by theking549 View Post
    Hello, guys need help I have a 2008 seadoo rxt-x I've had the ski for five years, the cluster was broken with water inside for two years I finally saved up and just bought a brand new cluster from seadoo online took it to my nearest dealer and had them program it, now cluster shows 0 hours, compass shows t 255 Rpms shows 0 or 5000 outside temp not working speedometer shows 0, I took it back to them and argued they did not program it properly they state there's nothing else they can do ? How did you guys fix this issue thanks
    They got the wrong firmware on it wow amazing they would leave it this way .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 2006-2007 Seadoo gti gauge cluster brand new.
    By MILLER PHASE 3 1050 in forum Sea Doo Classifieds
    Replies: 10
    Last Post: 11-21-2015, 10:42 PM
  2. SOLD New gauge cluster 278 002 270
    By crashhard in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 07-24-2014, 04:08 PM
  3. FS - Parts 2006-2007 Seadoo gti gauge cluster brand new.
    By MILLER PHASE 3 1050 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 04-07-2014, 04:13 PM
  4. FS NEW Backlit Red 06+ RXT Display Gauge Cluster 0hrs!
    By boostaholic in forum Sea Doo Classifieds
    Replies: 20
    Last Post: 07-08-2013, 12:08 AM
  5. FS - New in Package - Gauge Cluster and Exhaust Manifold
    By Shibby1485 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 08-20-2008, 10:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •