Results 1 to 4 of 4
  1. #1

    RXT-X 2008 partial power loss and vibration

    My RXT-X 2008 is vibration alot, already replaced propeller, sleeve, and carbon ring set and still have high vibration at all speeds.
    Also much less power, struggles to reach 8000 rpm with 4" kanaflex and some other changes. Used to get to 8200 in a second!

    SC had was serviced at 66h due to oil leak as usual, all bearings, viton seal, needle pins, washers and dented wheel, it has nopw 110h could it be something to do with sc?? I was delaying SC service because of previous service, but might that be the cause??

    Another thing i noticed when i replace glow plugs yesterday, middle cylinder glow plug was a bit blue on the metal part outside cylinder, while other two were perfectly normal.
    Replaced them just to get it out of my mind, but problem remains.

    Will have to service SC probably, but hard to get kits at decent price in europe.



  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Nederland, Texas
    Check the pump.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    +1 on checking the pump.
    Take it out and look it over.

    Why did you replace the impeller??
    Also a blue spark plug doesn't sound good.

  4. #4
    I replaced prop because some rocks damaged it some time ago. Had a riva 15/22 r but got damaed so returned to OEM. Beginnig of this year replaced with new ring and new propeller.

    Already looked into intake and can't find anything there.

    What can cause blue glow plug??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help! 1996 Kawasaki 900 ZXi sound change and power loss
    By 1998232v6 in forum Kawasaki Open Discussion
    Replies: 11
    Last Post: 07-14-2013, 11:52 AM
  2. 2008 RXT-X power loss, experts advice needed..
    By Scarpa in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-12-2013, 08:40 AM
  3. HELP: 2008 GTX Power Loss, where to start looking????
    By larry1302 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-12-2010, 09:39 PM
  4. Replies: 6
    Last Post: 07-06-2008, 09:48 PM
  5. 2006rxp Sudden Loss of power and vibration
    By filterthis2008 in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-08-2008, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts