Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    rsracin05's Avatar
    Join Date
    Aug 2011
    Location
    MAINE
    Posts
    176
    +1
    2

    Looking at a 03 Genesis

    So I have one for sale near me. Guy said it runs good. Reverse doesn't work, hole in seat, but said it runs great. I recently sold my other 2 Polaris skis but this is a different animal. Anything to look for has about 160 hrs. Thanks


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Fuel injected or carburetor?

    Reverse is electrically powered PERC system.

    The normal Polaris 2-stroke evaluation process applies. Compression, drive line, etc.

    Genesis is very similar to the Virage models in terms of engine, drive line, electrical, even upper deck. Wider and longer than Virage, very stable. Runs around low 50mph.

  3. #3
    rsracin05's Avatar
    Join Date
    Aug 2011
    Location
    MAINE
    Posts
    176
    +1
    2
    Its a DI. He has someone looking at it now for 1800 no trailer. I'm second in line

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by rsracin05 View Post
    Its a DI...
    If it was me I would insist on a water test.

    These engines can seem OK out of the water but may not run quite right in the water.

    Water test should be at least 20 minutes of actual riding time at speed. If the EMM has issues they may not be apparent right off the bat until everything gets warmed up.

    Engine RPM should be right around 6700 at wide open sustained.

  5. #5
    rsracin05's Avatar
    Join Date
    Aug 2011
    Location
    MAINE
    Posts
    176
    +1
    2
    ok thank you for the help!!!

  6. #6
    rsracin05's Avatar
    Join Date
    Aug 2011
    Location
    MAINE
    Posts
    176
    +1
    2
    Ok I got some more info from the guy. he said he installed a used computer brain so hrs shown not accurate about 140. He also said without reverse it is limited to 4000 rpm. Is this right? Im not sure what to offer here is a link to the add. http://maine.craigslist.org/boa/3935012029.html He said he would take 1600.

  7. #7
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4
    4000 rpm is limp mode. Something is not quite right to have the engine at limp mode. If the rev is messed up then that could cause the problem. There are several other things that can cause limp mode also.

  8. #8
    rsracin05's Avatar
    Join Date
    Aug 2011
    Location
    MAINE
    Posts
    176
    +1
    2
    Anything In particular to look for /at I have comp gauge. These easy to fix possibly for limp mode problems. He said reverse is not working. Goin to look at it later. Thanks is this a ok price. I may just get it

  9. #9
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    The hour meter may not be accurate, but the computer does not display the hours. The display tracks them on its own. If it is displaying 160, it has at MINIMUM, 160. May be more.

    There should be a easly accessable connector in line with the wirirng to the reverse motor on the genesis. Unplug it and see if the rev limit goes away. If it does, its because the reverse broke in a position other than "Forward" if not, then it is more likley than not that there is a more serious issue.

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by rsracin05 View Post
    Ok I got some more info from the guy. he said he installed a used computer brain so hrs shown not accurate about 140. He also said without reverse it is limited to 4000 rpm. Is this right?

    Im not sure what to offer here is a link to the ad.
    http://maine.craigslist.org/boa/3935012029.html He said he would take 1600.
    Quote Originally Posted by rsracin05 View Post
    Anything In particular to look for /at I have comp gauge. These easy to fix possibly for limp mode problems. He said reverse is not working. Goin to look at it later. Thanks is this a ok price. I may just get it
    The asking price does not matter until you know what you are actually looking at.

    There are two separate but related things involving PERC reverse. The reverse motor or mechanism may have failed, possibly while not in the fully forward position. This would cause the reverse bucket to be stuck in the wrong position, perhaps just slightly down.

    The bigger issues is that the engine system is designed to limit engine RPM to 3500 when ever the reverse mechanism is anywhere but in the full forward mode. So if the EMM thinks Reverse mode is active then RPM will be limited. If the MFI display is working then the message Reverse should appear and possibly a red flashing lamp that continues flashing.

    However, and this is the important point, if the EMM thinks reverse is not engaged and everything should be OK for full forward and the engine still does not provide full RPM then there is some other issue. This could be a $200 sensor or some other simple fix or it could require a $700 EMM repair.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looking at a 03 MSX140
    By rsracin05 in forum MSX/Matrix
    Replies: 2
    Last Post: 08-27-2014, 01:00 PM
  2. Looking at buying a 99 Polaris Genesis need advice
    By PetroMan in forum Polaris Open Discussion
    Replies: 5
    Last Post: 09-02-2013, 02:13 AM
  3. Looking at an '03 Vans Triple Crown
    By Ryguy425425 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 03-14-2013, 02:17 PM
  4. Looking at purchasing a 2000 Polaris Genesis, any feedback?
    By Ronski22 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-25-2011, 05:18 PM
  5. Look at what I did now...
    By oneal in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-29-2005, 06:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •