Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Am I missing something? .... 2001 Polaris Genesis TPS Assembly

    hey guys just wondering if you can help me out before the weekend. so here it is, i bought this polaris knowing the EMM was out and so i got that fixed and now its running but wont throttle. come to find out that the TPS is just gone. so i looked them up and ordered one that is coming friday. the thing is that i looked at the part and where the part goes and it doesnt seem to match up to me like theres something missing. idk i could be wrong but here take a look.

    Click image for larger version. 

Name:	Evinrude TPS 5001793.jpg 
Views:	56 
Size:	71.6 KB 
ID:	306983
    The Part

    Click image for larger version. 

Name:	IMG_3940[1].jpg 
Views:	49 
Size:	66.1 KB 
ID:	306984Click image for larger version. 

Name:	IMG_3942[1].jpg 
Views:	46 
Size:	66.2 KB 
ID:	306985Click image for larger version. 

Name:	IMG_3943[1].jpg 
Views:	42 
Size:	62.2 KB 
ID:	306986
    The Destination


  2. #2
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Looks like the cam is missing or its a set from a 02+. Not sure which. Im sure someone will chime in soon.

  3. #3
    What cam are you talking about, is there a way I can just get the cam ???

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by ghostinstallations View Post
    Looks like the cam is missing or its a set from a 02+. Not sure which. Im sure someone will chime in soon.
    Confirm the model year from the last two digits from the HIN number plate on the rear deck.

    Either the throttle body is from 2002-2004 (and mates with the pigtail style TPS) or the lever arm is missing from the rear end of the throttle shaft.

    The non-pigtail TPS you have shown has slotted mounting holes, so it is not the official Polaris part. The slotted version will work, but you must tweak the mounting rotation until the TOS provide the correct idle signal voltage to the EMM.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by xBrenneckex View Post
    What cam are you talking about, is there a way I can just get the cam ???
    Somewhere around here there must be some photos of the proper throttle body shaft end.

    Is it possible that tiny metal part is hiding under the engine or the rear of the hull?

  6. #6
    well the i tried to look for it but found nothing but it is hard to look under there so it could be

  7. #7
    but truthfully some photos would help me on what im looking for and an idea of things

  8. #8
    fixer's Avatar
    Join Date
    Feb 2011
    Location
    Mass
    Posts
    498
    +1
    20
    Click image for larger version. 

Name:	DSC02979.jpg 
Views:	49 
Size:	85.4 KB 
ID:	307107
    Old style ion the left, new on the right. Looks to me like someone removed the nut & lever then ground off the threads in an effort to retrofit the old style throttle body with the new style TPS.

  9. #9
    Quote Originally Posted by fixer View Post
    Old style ion the left, new on the right. Looks to me like someone removed the nut & lever then ground off the threads in an effort to retrofit the old style throttle body with the new style TPS.
    So wait do those throttle bodies have the lever or piece that will move the tps or no?? sorry its hard to tell but thank you for getting that pic

  10. #10
    fixer's Avatar
    Join Date
    Feb 2011
    Location
    Mass
    Posts
    498
    +1
    20
    The one on the left does, the one on the right doesn't. the throttle shaft itself is inserted into the tps on the newer style so no need for the lever.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts Polaris Genesis TPS - new in package (fits 1999-2001 Ficht)
    By rjcapo02 in forum Polaris Classifieds
    Replies: 2
    Last Post: 09-13-2012, 06:54 AM
  2. 2001 Polaris Genesis Voltage Regulator
    By viperjohn in forum Polaris Classifieds
    Replies: 1
    Last Post: 05-07-2009, 08:50 PM
  3. 2001 polaris genesis, OVERHEAT
    By mixx911 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-23-2008, 09:15 PM
  4. Am I missing something here?
    By Tony in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-19-2007, 11:30 PM
  5. 2001 Polaris Genesis won't start
    By Blink in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 01-11-2007, 09:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •