Results 1 to 6 of 6
  1. #1

    Join Date
    Jan 2007
    Location
    JEDDAH
    Posts
    213

    Angry New Impeller & Ss Wear Ring

    I Have Installed New Solas Impeller With

    Ss Wear Ring For My Rxp 06 , I Have Notice

    When I Spine It By Hand It's Scratched To

    The Ss Wear Ring Slightly AND I HAVE TURN MORE

    , IT'S STOPPED I CAN'T MOVE I HAVE TO MAKE

    POWER TO TURN IT , Is This IS Normal

    Thing When It's New ,please Reply Me

    I Woon Install The Hole Pump Back Into My Ski

    Thanx 4 Allllllllllllllllll
    Last edited by LAB69; 03-06-2007 at 03:46 PM.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Are the threads engaging in the prop? If not you probably just have it cocked sideways a bit. Once you get it seated properly and tightened down it should spin freely with a very tight clearance between the prop and wear ring.

  3. #3

    Join Date
    Jan 2007
    Location
    JEDDAH
    Posts
    213
    Quote Originally Posted by Green Hulk View Post
    Are the threads engaging in the prop? If not you probably just have it cocked sideways a bit. Once you get it seated properly and tightened down it should spin freely with a very tight clearance between the prop and wear ring.
    I HAVE DONE IT AT THE MACHINE CENTER , THEY ARE

    VERY GREAT IN INSTALLING LIKE THIS KIND OF JOB ,

    HE ENGAGED THE THREADS TO THE PROP EASY , I HAVE

    CHECKED THAT BY MY SELF BUT WHEN WE TIGHTED THE NUT

    IT SCRATCHED FROM ONE SIDE, FYI I HAVE REPLACE THE

    ANGLE BEARING WITH A NEW ONE , THANX 4 THE REPLY

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    As long as the impeller spins freely by hand you should be fine.

  5. #5

    Join Date
    Jan 2007
    Location
    JEDDAH
    Posts
    213
    Quote Originally Posted by Green Hulk View Post
    As long as the impeller spins freely by hand you should be fine.
    BUT IT STOPPED IN ONE SIDE IT DOSE NOT MOVE

    EVEN BY HAND , I WILL REMOVE THE PROP OUT

    TOTALLY AND I WILL TRY TO FIX IT AGINE AND I WILL SEE

    WHAT IS WRONG ,,,,,,ANY WAY THANX FOR THE REPLY

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by LAB69 View Post
    WHAT IS WRONG ,,,,,,ANY WAY THANX FOR THE REPLY
    Your guess is as good as mine. You mentioned replacing the pump bearing. I would look for a mistake made there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New solas impeller and SS wear ring 2006 RXP
    By speeder in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-28-2015, 12:46 AM
  2. Help!!! Impeller contacting SS wear ring...
    By t_hoang02 in forum 4-Tec Performance
    Replies: 7
    Last Post: 12-30-2009, 10:44 PM
  3. New SS wear ring
    By HOSS in forum 4-Tec Performance
    Replies: 21
    Last Post: 10-08-2008, 05:50 PM
  4. Greenwheel, RXT driveshaft, 14/19r impeller, SS wear ring, ECU
    By jpeconsult in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-11-2008, 03:05 PM
  5. New impeller rubbing on new ss wear ring...
    By Alaska05RXT in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-16-2007, 02:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •