Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    1995 polaris slt 750 not starting

    Where should I start please help


  2. #2
    ThrottleOut's Avatar
    Join Date
    Aug 2011
    Location
    Corning, NY
    Posts
    727
    +1
    29
    This is a good place to start reading: http://polarispwcknowledge.shorturl....is-fuji-engine

    What is the history of the ski? Has it ever run for you? Does it turn over? What's the battery voltage resting and what is it while cranking?

    I'd start by checking the battery and then check compression on the motor. From there you'll want to run through the fuel system as the fuji engines are known to have weak fuel pumps and other issues which can cause the engine to do a lean burn down and melt a hole in the MAG cylinder (it's last in line for the fuel supply).

  3. #3
    I just bought it. It had a hole in the first piston close the close to stering wheel . Well I changed that and not starting I was told it started but would only run like 30 mph with the broke piston. But that's all changed. It does turn over. The battery is good cause I had it tested. I believe it does have the old fuel pump on and not the upgraded one triple fuel pump? Is there anyway to spray starting fluid into engine to see if that the problem? Also it doesn't look right but is the battery supposed to be on the black cdi box? I pressed reset to see if that would work and nothing . In the front of the ski on front of first piston there is a blue circle part there is a hole that something screwed in to there that not there that wouldnt be problem would it?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by fryestyle16 View Post
    I just bought it...
    Start here.

  5. #5
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    The Electrical box does mount on top of the battery. Be sure the plastic battery cover is in place or you will create a dead short and possibly burn up the stator ground, causing the ski not to start, and potentially destroying the stator.

  6. #6
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by K447 View Post
    Quote Originally Posted by fryestyle16 View Post
    I just bought it...
    Start here.
    +1

  7. #7
    yea the battery is on the box. should i put the box on the battery also i dont have a cover.

  8. #8
    does the display only turn on when the machine is completey runing?

  9. #9
    im just temped to take it to the local dealer ship im not a machinc and that piston was hard to get on. espically with the engine inside the unit.

  10. #10
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by fryestyle16 View Post
    yea the battery is on the box. should i put the box on the battery also i dont have a cover.
    You need the cover, or you need to fabricate some sort of non - conductive barrier. Do you have the elastic straps to hold the ebox and battery in place?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 02-07-2016, 05:49 PM
  2. 1995 Polaris SLT 750 are these OEM pistons or not?
    By jajardas in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-20-2014, 02:26 PM
  3. Parting out Whole 1995 Polaris SLT 750
    By cubsfan2516 in forum Polaris Classifieds
    Replies: 34
    Last Post: 04-11-2013, 06:15 PM
  4. 1995 Polaris SLT 750 Stops and then starts again stops and starts again....
    By piatkowski6 in forum Polaris Tech Tips and Info
    Replies: 49
    Last Post: 02-16-2013, 03:40 AM
  5. 1995 polaris slt 750
    By Daveb in forum Polaris Open Discussion
    Replies: 55
    Last Post: 07-09-2009, 10:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •