Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    Join Date
    Jul 2013
    Location
    Roanoke, VA
    Posts
    16

    Ultra 250x low rpm, 10psi, 56mph

    My 07 250x (46hrs) has performed flawlessly until this summer - boost guage shows 10psi max, RPM won't pass 6700. GPS shows max speed of 56mph, and acceleration is definitely off. SC belt is tight (toward the tight end of good using the special tool)and appears to be in good condition. Bypass valve and blowoff valve do not leak at WOT, no damage to impeller/pump, clearance is .006". Tried 3 different sets of plugs (PFR9B, CR9EK, CR9EIX) . Oil is not overfull, IC is clean with no leaks. Air horn firmly glued in place, clear tube empty.

    I've pressure tested the water passages in the intercooler, no leaks. Pulleys appear OK, bearings smooth and barely perceptible side play. SC turns smoothly and has proper oil level, oil looks good. I've wiped out the "well" under the SC found very small amount of oil residue.

    Two rides later with no change:

    New SC belt installed, BOV blocked off. Still performs poorly. 6700rpm, 10psi, 56mph. No codes in self diagnostic. One odd issue - throttle does not make any difference in last 20% of travel. Checked throttle for full opening, with IC hose off. All sensors are within spec per Kawasaki service manual, except TPS. TPS voltage check shows 1.08v at idle setting (low end of good) but resistance shows 2.8k ohm at idle where good range is 4-6k. Resistance shows a smooth progression through throttle travel to .89k at full throttle. Is my TPS resistance at WOT correct?(0.89k ohm) I couldn't find a spec for this.

    Could the TPS be the culprit, or is this reading "close enough"???

    Anything I'm missing?


  2. #2
    UltraKvz's Avatar
    Join Date
    Feb 2011
    Location
    Earth
    Posts
    378
    +1
    23
    Check your pump and impeller pitch too!

  3. #3

    Join Date
    Jul 2013
    Location
    Roanoke, VA
    Posts
    16
    Pump bearings smooth, stock impeller with no damage.

  4. #4

    Join Date
    Jul 2013
    Location
    Roanoke, VA
    Posts
    16
    Replaced TPS. No change.

    Ideas??? Anyone???

  5. #5
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Exhaust Manifold water leak

  6. #6
    Quote Originally Posted by merlinbasenji View Post
    ...Anything I'm missing?
    Id say that's remarkably thorough. You even glued in the airhorn.

    Did you actually use the search button before you posted?

    Tell us if NJ is right. Id bet even money on it.

  7. #7

    Join Date
    Jul 2013
    Location
    Roanoke, VA
    Posts
    16
    I did search before posting, found lots of good ideas/suggestions, including exhaust manifold gasket leak. From what I remember reading, a leaky gasket would allow water to leak into the cylinders while on hose and not running. I checked for that when doing a compression test, since the plugs were out anyway. I didn't see any evidence of water flowing into the cylinders while on hose and not running. Is this a definitive test? I don't mind replacing the gasket if suspect.

    I haven't been able to find any mention of the throttle issue though (last 20-25% of throttle travel seems to make no difference in how the engine runs), is this a symptom of leaky manifold gasket?

  8. #8
    UltraKvz's Avatar
    Join Date
    Feb 2011
    Location
    Earth
    Posts
    378
    +1
    23
    I think what nj meant was exhaust gasses leaking into the engine compartment.

  9. #9

    Join Date
    Jul 2013
    Location
    Roanoke, VA
    Posts
    16
    NJ & Ultra - you're right on point. I just made a test run with seat off... 7300rpm and felt much better. No GPS or boost reading. So I'm assuming the manifold gaskets are the most common leak?

    Thanks again - I knew someone on here has had similar issues and would know where to look!

  10. #10
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    No i meant exhaust gasket manifold water leak not gases if you have gas leak you would have water leaks.

  11. +1 by:


Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 250x low rpm, 10psi, 56mph
    By merlinbasenji in forum Kawasaki PWC Performance (4-stroke)
    Replies: 23
    Last Post: 06-13-2016, 03:15 PM
  2. 2007 Kawasaki Ultra 250X low rpm
    By saynotospam in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 08-10-2011, 09:57 PM
  3. Ultra 250x low rpm
    By strok-n in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-10-2011, 08:14 PM
  4. Ultra 250x, Low boost & rpm.
    By Petros_GR in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 05-10-2010, 10:51 AM
  5. FS: 07 ultra 250x LOW PRICE warranty
    By john07ex in forum Kawasaki Skis
    Replies: 12
    Last Post: 11-05-2008, 11:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •