Results 1 to 4 of 4
  1. #1

    1997 Polaris SLT 700 - Engine won't reach top speed under load

    Hi Everyone,
    So I had both of my carbs and fule pump re-built by a local shop and they also installed a new battery. They checked the compression and reported 135 p.s.i. in both cylinders. New plugs were also gapped and installed The problem is that I can't get the ski above about 3/4 throttle, it could be less. When I catch a wake it will rev to wide open, but then settle down to half speed again. I've pumped out any old gas and filled with fresh gas. I don't know where to go with this. Suggestions of what to look for?

    Thanks!


  2. #2
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    853
    +1
    19
    Wrong impeller maybe?

  3. #3
    Quote Originally Posted by stimpsonjcat View Post
    Wrong impeller maybe?
    It has had the same impeller for the last 10 years. The mechanic told me that the carbs on this machine were factory set so there is no adjustment. Is that true?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by stinger2850 View Post
    Quote Originally Posted by stimpsonjcat View Post
    Wrong impeller maybe?
    It has had the same impeller for the last 10 years. The mechanic told me that the carbs on this machine were factory set so there is no adjustment. Is that true?
    The Keihin carbs on Polaris watercraft only have a low speed screw adjustment. Everything else is controlled by the jetting inside the carbs.

    So the carbs were rebuilt and now you are down on power, correct?

    Perhaps the carb rebuild was not done properly...

    You can squeeze the handlebar throttle fully open, but the engine does not respond?

    Make sure the actual throttle blades inside the carbs are fully opening when the thumb lever is fully squeezed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 polaris slt 700, Engine missing and plug fouling
    By crazykid2004 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 07-17-2013, 11:15 PM
  2. 1997 Polaris SLT 700
    By turbotia in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-10-2013, 08:13 PM
  3. 1997 polaris slt 700 issues
    By dlparsons10 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-09-2013, 08:17 PM
  4. 1997 Polaris SLT 700 no spark
    By greenbean in forum Polaris Tech Tips and Info
    Replies: 10
    Last Post: 09-07-2012, 04:55 PM
  5. 1997 polaris SLT 700
    By Bdiddy in forum Polaris PWC Performance
    Replies: 2
    Last Post: 04-26-2010, 04:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •