Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 39
  1. #1

    1999 slx 1050 project

    I picked up a 1999 slx 1050 project. The ski needs an engine. I took the engine out today and stripped it down to send out as a core for a rebuilt. The engine came out easy but as expected I ran into a few problems. The impeller doesn't spin, is it common for the bearings to seize? This ski sat outside uncovered for a year. The impeller doesn't look stuck on the wear ring. Also the four long jet pump bolts came out but 1 bolt took off part of the ear where the threads are on the back end of the jet pump near the hull. Also I noticed timing marks on the flywheel. When I get my new engine do I have to time the engine with a special tool? I'm also wondering if I'm lucky enough to have the updated stator? Hope the pics I took help determine that.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	75 
Size:	90.7 KB 
ID:	307392   Click image for larger version. 

Name:	image.jpg 
Views:	69 
Size:	109.1 KB 
ID:	307393   Click image for larger version. 

Name:	image.jpg 
Views:	78 
Size:	125.6 KB 
ID:	307394   Click image for larger version. 

Name:	image.jpg 
Views:	81 
Size:	114.2 KB 
ID:	307395  


  2. #2
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Sounds like the pump bearing are seized. It happens. Is it a saltwater ski? So did you lose the total ear where you can not put a bolt in it? If so you will need a need a new housing. Can't run it with only 3 bolts. What color is the Potting on the CDI? It's the black box inside you electric box and has a serial connector on it. The upgraded version should be black, the older version is brown. What was wrong with the engine,If burnt down or bad crank the ski was running when it happen so the ign system should be good. And yes you will have to set timing. the stator will be mounted a little different ans on every crank the keyway can be off some.

  3. #3
    Quote Originally Posted by Keddano View Post
    Sounds like the pump bearing are seized. It happens. Is it a saltwater ski? So did you lose the total ear where you can not put a bolt in it? If so you will need a need a new housing. Can't run it with only 3 bolts. What color is the Potting on the CDI? It's the black box inside you electric box and has a serial connector on it. The upgraded version should be black, the older version is brown. What was wrong with the engine,If burnt down or bad crank the ski was running when it happen so the ing system should be good. And yes you will have to set timing. the stator will be mounted a little different ans on every crank the keyway can be off some.
    Thanks for the info. Yes it was a salt water ski. When cranking two of the engines pistons would move more than the third. The engine apears to have been hydrolocked and I think has a bent rod but I haven't torn it down yet.
    When i took off the intake the middle cylinder was full of what looked like sand and salt.water. it also sat outside uncovered for a year. I'm gonna check the cdi out tomorrow. Still not sure if im gonna rebuild it myself or buy a rebuilt engine. As for the jet pump housing, im gonna need a new one.I soaked them in pb but the 1 bolt didn't wanna cooperate. I can get a few threads to catch but that's it.

  4. #4
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    Quote Originally Posted by Mack View Post
    Quote Originally Posted by Keddano View Post
    Sounds like the pump bearing are seized. It happens. Is it a saltwater ski? So did you lose the total ear where you can not put a bolt in it? If so you will need a need a new housing. Can't run it with only 3 bolts. What color is the Potting on the CDI? It's the black box inside you electric box and has a serial connector on it. The upgraded version should be black, the older version is brown. What was wrong with the engine,If burnt down or bad crank the ski was running when it happen so the ing system should be good. And yes you will have to set timing. the stator will be mounted a little different ans on every crank the keyway can be off some.
    Thanks for the info. Yes it was a salt water ski. When cranking two of the engines pistons would move more than the third. The engine apears to have been hydrolocked and I think has a bent rod but I haven't torn it down yet.
    When i took off the intake the middle cylinder was full of what looked like sand and salt.water. it also sat outside uncovered for a year. I'm gonna check the cdi out tomorrow. Still not sure if im gonna rebuild it myself or buy a rebuilt engine. As for the jet pump housing, im gonna need a new one.I soaked them in pb but the 1 bolt didn't wanna cooperate. I can get a few threads to catch but that's it.
    check out the inside of the e box and check condition. Seriously. Looks like alot of work and new parts. Always consider what you will have in the ski vs what a good running ski cost. Don't get too upside down with it.

  5. #5
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    That stator is the original, not updated.

  6. #6
    Quote Originally Posted by Keddano View Post
    Quote Originally Posted by Mack View Post
    Quote Originally Posted by Keddano View Post
    Sounds like the pump bearing are seized. It happens. Is it a saltwater ski? So did you lose the total ear where you can not put a bolt in it? If so you will need a need a new housing. Can't run it with only 3 bolts. What color is the Potting on the CDI? It's the black box inside you electric box and has a serial connector on it. The upgraded version should be black, the older version is brown. What was wrong with the engine,If burnt down or bad crank the ski was running when it happen so the ing system should be good. And yes you will have to set timing. the stator will be mounted a little different ans on every crank the keyway can be off some.
    Thanks for the info. Yes it was a salt water ski. When cranking two of the engines pistons would move more than the third. The engine apears to have been hydrolocked and I think has a bent rod but I haven't torn it down yet.
    When i took off the intake the middle cylinder was full of what looked like sand and salt.water. it also sat outside uncovered for a year. I'm gonna check the cdi out tomorrow. Still not sure if im gonna rebuild it myself or buy a rebuilt engine. As for the jet pump housing, im gonna need a new one.I soaked them in pb but the 1 bolt didn't wanna cooperate. I can get a few threads to catch but that's it.
    check out the inside of the e box and check condition. Seriously. Looks like alot of work and new parts. Always consider what you will have in the ski vs what a good running ski cost. Don't get too upside down with it.

    I'm quickly seeing how the cost of this project can spiral out of control. I need an engine, jet pump, jet pump housing, updated stator, LCD screen, carb rebuild kit, and traction mats. I'm sure there will be more. I really want a restoration project. I just need to decide if this ski is worth the investment and time.
    Last edited by Mack; 08-27-2013 at 07:32 PM.

  7. #7
    A little good news. My jetpump bearings weren't seized. The housing deformed and the impeller got stuck on the housing. Took some time but I was able to get it apart without damaging anything.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	57 
Size:	64.4 KB 
ID:	307606  

  8. #8
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Be sure to check your impeller to wear ring clearance once you source a new wear ring. Hopefully the wear ring didn't slowly distort and the impeller didn't slowly grind itself down until it seized....

  9. #9
    A
    Quote Originally Posted by BlueFishCrisis View Post
    Be sure to check your impeller to wear ring clearance once you source a new wear ring. Hopefully the wear ring didn't slowly distort and the impeller didn't slowly grind itself down until it seized....
    Ill definitely check that once I get the new housing.

  10. #10
    What's the best way to split the 1050 crankcase without damaging it? Also can the steering pad be painted or will the paint eventually chip off? Also need to paint the mirrors. Any suggestions on what kind of paint I should use?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	58 
Size:	92.5 KB 
ID:	308686   Click image for larger version. 

Name:	image.jpg 
Views:	55 
Size:	83.3 KB 
ID:	308687  

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 SLX 1050 has weak spark
    By oachs83 in forum Polaris Open Discussion
    Replies: 28
    Last Post: 09-21-2009, 04:43 PM
  2. 1999 SLX 1050 giving me a headache
    By oachs83 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 06-27-2008, 04:05 PM
  3. WTB 1999 slx 1050 hood, hinge, and access.
    By csl3ch in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-13-2008, 12:44 PM
  4. 1999 slx 1050 fuel system
    By rmaser in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 05-30-2008, 10:31 PM
  5. 1999 slx 1050 looses power
    By Pauly in forum Polaris Open Discussion
    Replies: 4
    Last Post: 02-15-2008, 07:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •