Results 1 to 7 of 7
  1. #1

    Pump is friggen STUCK

    Trying to pull a pump on a 2012 VX1100. Pulled the four bolts that hold the steering nozzle. Tried using the lil notches on both sides to pry the pump apart but it wouldn't budge. I then attached a rope to a tree and tried the "ratchet" technique and the ratcheting strap snapped. I then tied a rope to the pump and drove the truck and trailer forward very slowly, rope snapped. whats the deal guys, is there a bolt i'm missing. Do i need to pull the cone and back out the inmpeller from the drive shaft? I have the service manual and I think i'm following it precisely.


  2. #2
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    remove the four 14mm and one 10mm bolts and pull the wear ring with it, then separate it in the bench, reinstall after you get it cleaned up, my was very hard to pull the first time

  3. #3
    Quote Originally Posted by big john View Post
    remove the four 14mm and one 10mm bolts and pull the wear ring with it, then separate it in the bench, reinstall after you get it cleaned up, my was very hard to pull the first time
    I have pulled the 4 14 mm long bolts holding the pump and the 4 14mm bolts holding the wear ring. I did not see any 10mm bolts. I have removed all the rubber sound suppression, reverse, and sterring linkage. I have also dropped the ride plate and pulled the intake grate but the pump and wear ring are friggen stuck on there.

  4. #4
    After inspecting again the 10mm was removed, I have removed every bolt I can find. This sucks

  5. #5
    I'm with the cool kids Mowerpan's Avatar
    Join Date
    Mar 2008
    Location
    Bradenton,FL
    Posts
    172
    +1
    12
    It is always hard to get off. Remove the rideplate to give you access from below. Use a pry bar like one used for pulled nails, place a 2x4 piece of wood against the hull and use this to pry against with the 90 degree portion contacting the pump. Do this for each side and go back and forth.

  6. #6

  7. #7
    Guidoo's Avatar
    Join Date
    Jul 2011
    Location
    Living outside of Charleston SC.
    Posts
    2,206
    +1
    458
    Yamaha uses silicone to seal these pumps. When I pulled the pump on my ol VX it was a beotch. Just pry easy and steady at the pry points.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 250 pump...?? Is it a 148??
    By jonny5 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 03-14-2009, 06:29 PM
  2. Performance Fuel Pump,is it needed for stage2?
    By novice_4 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-03-2006, 10:06 PM
  3. Ok - My pump is going to Skat
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 25
    Last Post: 04-13-2006, 01:30 PM
  4. While the pump is out.................
    By BULLRAIDER in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 02-06-2006, 09:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •