Results 1 to 7 of 7
  1. #1

    Unhappy Stock 08 RXT running a solas 13/19 impeller?? Bad??

    Tell me I didn't just screw up royally and waste my time and money purchasing and installing a solas 13/19 impeller! I swore I read that that one was the perfect impeller for stock/stage 1 so I ordered it along with the R&D grate, Opas block outs and a stainless steal wear ring since my stock prop and wear ring were toast........very uneasy right now, experts chime in...


  2. #2
    ABUDHABI boost your life's Avatar
    Join Date
    Dec 2009
    Location
    uae
    Posts
    95
    +1
    1
    yesterday i installed solas 13/19 on my RXT-X 255 with STAGE 1 and its the best impller till now i have installed speed 70 GPS RPM 8140.

    i installed 15/22 RPM7600

    i installed 15/20 RPM 7800 gps 68

    now my ski has 25 Hour which is new ski

  3. #3
    ABUDHABI boost your life's Avatar
    Join Date
    Dec 2009
    Location
    uae
    Posts
    95
    +1
    1
    For Your Information we checked the solas 13/19 on the gauge and it was 12.5/18.5 !!!!

  4. #4
    Good to know, makes me feel a little better....I think I saw some where that stock was 13/18.......taking it out today to see how it runs, hoping for the best....

  5. #5
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Relax, you will have great results. Look at my signature.

  6. #6
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by jpt7779 View Post
    Relax, you will have great results. Look at my signature.
    If you started with a 15/20 his prop will not be like yours. Different root angle.

  7. #7
    Test run went well, ski felt fast just as it did before, 69mph per the factory speedo on slight chop with 2 adults 8050RPM.....the muscle head guy in the loud wellcraft scarb couldn't keep up ! Initial take off still seemed to be a little hesitant, I'm assuming it may be due to the damaged pump veins......not knowing enough about the ski's inner workings I'm taking a guess sense 3 had 1/4 piece missing and a few others were pretty dinged up.....filed them down best I could. Could the damaged veins affect the initial take off?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS Solas 13/19 impeller for GP1200R amd others 140 shipped
    By j-wadd in forum Yamaha Classifieds
    Replies: 4
    Last Post: 07-27-2013, 07:44 PM
  2. WTB : Solas 13/19 Impeller For MSX 150
    By ride04msx in forum Polaris Classifieds
    Replies: 1
    Last Post: 08-05-2011, 08:11 AM
  3. Replies: 20
    Last Post: 06-15-2011, 01:27 PM
  4. Replies: 0
    Last Post: 11-24-2009, 06:18 PM
  5. Solas 13/19 impeller question!
    By ksako270 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 03-24-2008, 03:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •